Coller tant que cellule d'à côté non vide

Fermé
lolito_balmito
Messages postés
7
Date d'inscription
mercredi 21 août 2013
Statut
Membre
Dernière intervention
27 septembre 2013
- 27 sept. 2013 à 11:53
eriiic
Messages postés
24386
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 mai 2022
- 27 sept. 2013 à 15:25
Bonjour,

Je souhaite copier une formule en Vba dans la colonne B tant les cellules de la colonne A sont non vide.

Comment faire ?

Merci,
Laurent

2 réponses

eriiic
Messages postés
24386
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 mai 2022
7 074
27 sept. 2013 à 12:43
Bonjour,

double-cliquer sur la poignée de recopie (petit carré noir en bas à droite de la sélection)

eric
0
lolito_balmito
Messages postés
7
Date d'inscription
mercredi 21 août 2013
Statut
Membre
Dernière intervention
27 septembre 2013
1
27 sept. 2013 à 14:12
Merci Eric,

En fait j'ai besoin de mettre ça en Vba, c'est une de mes opérations dans une macro.
Pour le moment, je fais par exemple un :

Range("AE2").Select
ActiveCell.FormulaR1C1 = _
"=if(weekday(RC[-1])=3,RC[-1]-4,RC[-1]-2)" '=SI(JOURSEM(AD2)=3;AD2-4;AD2-2)
Selection.AutoFill Destination:=Range("AE2:AE500")

aux risques de m'arrêter trop tôt ...

Cordialement,
Laurent
0
eriiic
Messages postés
24386
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 mai 2022
7 074
27 sept. 2013 à 15:25
Re,

derlig=cells(rows.count,"A").end(xlup).row
te donne la dernière ligne occupée de la colonne A.

eric
0