PB avec formule NB.SI

[Fermé]
Signaler
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015
-
Messages postés
26182
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 septembre 2021
-
Bonjour,


Voilà, je dois rechercher dans un fichier de 670 ligne et de 20 colonne si un terme, au format standard, revient plusieurs fois. Pour cela j'utilise la formule
=NB.SI($K$2:$AD$669;"822-1369-003")

Je souhaiterais savoir si vous aviez une formule ou une idée pour m'éviter de faire du copié collé du terme à rechercher et ils sont nombreux.

Ci-joint le fichier (Excel 2010) : https://www.dropbox.com/s/1ehjdk9g57qazvk/test.xlsx

3 réponses

Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

Merci de votre aide
Bonjour,

Dans ta cellule A3 essayes avec =SOMME(SI($F$1:$Y$668=C3;1;0)) (formule a valider par CTRL+SHIFT+ENTREE ça met les {} des formules matricielles

dans ce cas ça cherche dans le tableau la valeur contenue en C3 (la ref) et ajoute 1 à chaque fois que trouvé
Messages postés
26182
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 septembre 2021
6 052
Bonjour
pour faire simple dans votre modéle:
remplacez en A3 votre code entre guillemets par C3 (sans guillemets)
et tirez la formule sur la hauteur utile.
Elle vous comptera le nombre de valeurs du champ dont la référence est en C sur la même ligne

Crdlmnt