Griser lignes WE et jours fériés [Résolu/Fermé]

Signaler
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015
-
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015
-
Bonjour,

J'ai regardé tous les forums qui traitent de ce sujet simple en apparence.
J'ai réussi à le faire fonctionner sur un tableau en "lignes", mais impossible sur celui que je vous joins ici...
J'ai tout essayé en vain. Alors si quelqu'un peut m'aider, merci d'avance...

https://www.cjoint.com/?CIprmibVzu2

En fait j'aimerais que toute la ligne soit grisée pour les WE et les jours fériés, et si possible, qu'un F vienne s'inscrire en colonne D quand il y a un jour Férié.
J'ai mis en page mon document tel que j'aimerais l'avoir en final, mais grâce à la fomule...

Merci infiniment
A voir également:

2 réponses

Messages postés
25749
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 714
Bonsoir

voyez votre fichier ici.

https://www.cjoint.com/c/CIps4oozGzU

notez bien les signes $ dans les formules de MFC et les limites de champ auxquelles elles s'adressent.
Je ne vous conseille pas de placer un F en D car ceci nécessite une formule qu'il faudra détruire pour renter un horaire.
Je vous ai proposé un renforcement en D de la signalisation par format.

Toutefois si vous voulez vraiment placer un F en D, la formule et en D8

=SI(OU(JOURSEM(A8;2)>5;NB.SI(fériés;A8));"F";"")

Crdlmt
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015

Bonsoir,

Merci pour votre aide, mais j'ai deux questions.
1) Pour la mise en forme conditionnelle,faut il la répéter colonne par colonne pour avoir la ligne complète, ou peut on la valider pour tout le tableau d'un seul coup?

2) La formule pour obtenir un F si c'est un jour férié ne fonctionne pas comme elle devrait. Il m'affiche un F sur tous les WE... ???

Merci de me dire, et merci encore de votre aide...

Cdlmt
Messages postés
25749
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 714
Bonjour

dans le modèle proposé:

la mise ne forme s'applique bien sur toute la ligne pour le gris, mais uniquement sur la colonne D pour la cellule D qui est en plus remplie avec des pointillés.
Si vous supprimer cette seconde MFC, la ligne restera bien grise de A à F avec la seule MFC restant.
Vous pouvez voir sur quelles zones s'appliquent les MFC en affichant la liste (fenêtre de droite dans l'affichage)

Si vous ne voulez le F que pour les jours fériés, la formule est:
=NB.SI(fériés;A8);"F";"")

crdlmnt
Messages postés
3004
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 janvier 2021
835
Bonjour

J'ai adapté une formule chipée sur un autre classeur pour inscrire Férié et aussi we pour les weekends.

voici le lien

https://www.cjoint.com/c/CIqguqQgzL7

En espérant que ça te convienne

Cordialement
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015

Bonjour à vous,

Merci beaucoup pour votre aide... Ça fonctionne... Merci encore pour votre patience et votre dévouement...

Bien cordialement,