Nas openmediavault Problème fstab

[Fermé]
Signaler
-
 Akuma -
Bonjour,





Au demarrage sans taper ctrl-D je ne peut pas demarrer a cause d'une erreur sur fstab je pense donc a un mauvais UUID / Montage je poste donc ici un blkid :

root@PC2:~# blkid

/dev/sdb1: LABEL="PACKARD BELL" UUID="D47888027887E21A" TYPE="ntfs"
/dev/sda1: UUID="749515c9-173f-42b8-3017-a5a8c86610be" TYPE="linux_raid_member"
/dev/sda2: UUID="cb70d273-c647-142f-3017-a5a8c86610be" TYPE="linux_raid_member"
/dev/sda3: UUID="1edb355f-ff6d-6b30-7951-ac60547c39ae" LABEL="DiskStation:2" TYPE="linux_raid_member"
/dev/sde1: UUID="8a619060-7ea5-4d95-adeb-794d8d5a06de" TYPE="ext4"
/dev/sde5: UUID="7d372203-0466-4435-b4bb-b892ffc542d7" TYPE="swap"
/dev/sdc: UUID="83b80efc-c7ac-c5fe-5553-46820131932c" LABEL="PC2:Secure" TYPE="linux_raid_member"
/dev/sdd: UUID="83b80efc-c7ac-c5fe-5553-46820131932c" LABEL="PC2:Secure" TYPE="linux_raid_member"
/dev/md8: LABEL="Secure" UUID="62efbd44-2f2f-49da-be7e-83b95912d2d8" TYPE="ext4"
/dev/md2: LABEL="1.42.6-3211" UUID="2627c39e-f8e3-49e0-9a61-926f2262e5a5" TYPE="ext4"

je tente de reparer le fstab a la mano mais je galère si quelqu'un pouvait me filer un petit coup de pouce je serait reconnaissant :
mon fstab :
 GNU nano 2.2.4             Fichier : /etc/fstab                       Modifié


# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=8a619060-7ea5-4d95-adeb-794d8d5a06de / ext4 errors=remount$
# swap was on /dev/sda5 during installation
UUID=7d372203-0466-4435-b4bb-b892ffc542d7 none swap sw $
/dev/sda3 / auto rw,user,noauto 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/sda1 /media/usb0 auto rw,user,noauto 0 0
/dev/sda2 /media/usb1 auto rw,user,noauto 0 0
/dev/sda5 /media/usb2 auto rw,user,noauto 0 0
tmpfs /tmp tmpfs defaults 0 0
# >>> [openmediavault]
/dev/sdb1 /media/D47888027887E21A ntfs defaults 0 2
UUID=2627c39e-f8e3-49e0-9a61-926f2262e5a5 /media/2627c39e-f8e3-49e0-9a61-926f226$
UUID=62efbd44-2f2f-49da-be7e-83b95912d2d8 /media/62efbd44-2f2f-49da-be7e-83b9591$
# <<< [openmediavault]



/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/sda1 /media/usb0 auto rw,user,noauto 0 0
/dev/sda2 /media/usb1 auto rw,user,noauto 0 0
/dev/sda5 /media/usb2 auto rw,user,noauto 0 0
tmpfs /tmp tmpfs defaults 0 0
# >>> [openmediavault]
/dev/sdb1 /media/D47888027887E21A ntfs defaults 0 2
UUID=2627c39e-f8e3-49e0-9a61-926f2262e5a5 /media/2627c39e-f8e3-49e0-9a61-926f226$
UUID=62efbd44-2f2f-49da-be7e-83b95912d2d8 /media/62efbd44-2f2f-49da-be7e-83b9591$
# <<< [openmediavault]


Merci d'avance a vous si vous avez besoin de quoi que ce soit en plus hésitez pas a demandez :D
Merci a vous ,
Akuma.

2 réponses

Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 420
Salut,

La seconde partie c'est le contenu actuel de ton fstab ?

Si oui, alors c'est normal il y a des entrées redondantes ;-(
Oui c'est le contenu actuel de mon fstab , je vois des trucs mais j'oses pas toucher parce que avec les UUID je m'y perd un peu x) il suffit que je supprime un bout pour que ça reparte ? ( si oui le quel :-p) parce que la c'est galere des que je reboot le nas je doit remettre ecran clavier et CG pour pouvoir ctrl+D donc >.<
Messages postés
1645
Date d'inscription
dimanche 28 avril 2013
Statut
Membre
Dernière intervention
15 août 2021
304
Ok va falloir démêler tout ça ... Je suis pas trop à l'aise avec le raid même si
j'envisage d'en faire chez moi (2x2To en RAID1 / 2x3To en RAID1) mais je n'arrête pas de procrastiner l'affaire :p

Ce qui met la zone (mais tu t'en doutes) c'est l'install en usb puis ensuite le passage en interne + l'os en USB. Pas simple ton histoire, et je me sens pas la démêler là. J'espère que mes questions auront aidé d'autres à y voir plus clair ...

Sinon c'est quoi ton bootloader et son fichier de config ?
Messages postés
36324
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 420
L'Os est installé sur une clé USB ^.^
;-\

Extrait du wiki :

USB sticks are not recommended as boot device.

If you are not able to boot the 0.4 installation media, try to disable the serial port in the BIOS settings.

OpenMediaVault does not support a data partition on the device where the operation system is installed. Therefore, please note that the whole disk device is occupied by the operation system. During the setup the device is parted into a partition used by /root and a swap partition. All existing data on drive are deleted during installation!

Note before installing: To install OpenMediaVault without problems please disconnect all harddisks except the one used for the OpenMediaVault operation system. After installing OpenMediaVault shutdown the system. Then reconnect the drives and restart OpenMediaVault to finish configuration.
Messages postés
1645
Date d'inscription
dimanche 28 avril 2013
Statut
Membre
Dernière intervention
15 août 2021
304
Cool, sans lire le wiki, j'avais bien senti "le loup" :p
Bootloader Grub :)
Bah oui mais l'install en USB est conseiller pour ne pas perdre un port sata pour l'OS ^^
alors du coup ça me perd ça ..
J'ai fait le parted -l si ça peut aider :)

root@PC2:~# parted -l


Model: ATA WDC WD10EZEX-08R (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number Start End Size Type File system Flags
1 131kB 2550MB 2550MB primary ext4 raid
2 2550MB 4698MB 2147MB primary linux-swap(v1) raid
3 4832MB 1000GB 995GB primary raid


Model: ATA WDC WD10EADS-00M (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 1000GB 1000GB primary ntfs


Error: The primary GPT table is corrupt, but the backup appears OK, so that will
be used.
OK/Cancel?
OK/Cancel? ok
Model: ATA ST3200826AS (scsi)
Disk /dev/sdc: 200GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
1 65,5kB 2148MB 2147MB
2 2148MB 200GB 198GB


Error: The primary GPT table is corrupt, but the backup appears OK, so that will be
used.
OK/Cancel? ok
Model: ATA ST3320820AS (scsi)
Disk /dev/sdd: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
1 65,5kB 2148MB 2147MB
2 2148MB 320GB 318GB


Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sde: 4005MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 3786MB 3785MB primary ext4 boot
2 3787MB 4003MB 216MB extended
5 3787MB 4003MB 216MB logical linux-swap(v1)


Warning: Unable to open /dev/fd0 read-write (Système de fichiers accessible en lecture
seulement). /dev/fd0 has been opened read-only.
Error: /dev/fd0: unrecognised disk label

Model: Linux Software RAID Array (md)
Disk /dev/md2: 995GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number Start End Size File system Flags
1 0,00B 995GB 995GB ext4


Model: Linux Software RAID Array (md)
Disk /dev/md8: 200GB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number Start End Size File system Flags
1 0,00B 200GB 200GB ext4



La part contre je suis paumé maintenant ^^
Mon grub =)
:
# If you change this file, run 'update-grub' afterwards to update

# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
GRUB_CMDLINE_LINUX_DEFAULT="quiet rootdelay=10"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"