Formule de moyenne [Fermé]

Signaler
Messages postés
44
Date d'inscription
jeudi 28 mars 2013
Statut
Membre
Dernière intervention
14 mars 2016
-
Messages postés
23604
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
-
Bonjour,
Je suis à la recherche d'une formule qui me permet de calculer la moyenne d'une plage de cellules bien déterminée. Mais le problème c'est que cette plage de cellules est très dispersée. Je m'explique: je souhaite insérer, dans la cellule C2, la formule de la moyenne de toutes les observations (de la colonne B) qui sont identifiées par le numéro "1" (dans la colonne A) , et puis insérer dans la cellule C3 la formule de la moyenne de toutes les observations (de la colonne B) qui sont identifiées par le numéro "5" (dans la colonne A) ...
Merci

4 réponses

Messages postés
943
Date d'inscription
mercredi 25 juin 2008
Statut
Membre
Dernière intervention
3 septembre 2020
197
Bonjour,

Pour vous aider du mieux que l'on peut, il est souvent conseillé de poster une image du tableur en question.
Messages postés
44
Date d'inscription
jeudi 28 mars 2013
Statut
Membre
Dernière intervention
14 mars 2016

https://www.cjoint.com/c/CHFq2vAWfil Voilà donc un échantillon de mon fichier de 6000 lignes. J'espère que ça vous soit utile. En fait, je souhaite faire la même chose pour la médiane que pour la moyenne. Est ce que c'est faisable ??
Merci
Messages postés
44
Date d'inscription
jeudi 28 mars 2013
Statut
Membre
Dernière intervention
14 mars 2016

J'ai oublié de mentionner que je souhaite que Excel insère la formule de moyenne des observations identifiées par le numéro 1 , dans la colonne C en face de chaque cellule comportant le numéro 1 dans la colonne A.
Merci
Messages postés
25466
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bonjour
A tirer sur la hauteur utile, si vous voulez la moyenne en face de chaque ligne contenant le 1 en A

=SI(A1=1;MOYENNE.SI(A:A;1;B:B))*

et idem avec 5 pour l('autre poste

et pour avoir ça dans une seule colonne:

=SI(A1=1;MOYENNE.SI(A:A;1;B:B);SI(A1=5;MOYENNE.SI(A:A;5;B:B);""))

crdlmnt
Messages postés
44
Date d'inscription
jeudi 28 mars 2013
Statut
Membre
Dernière intervention
14 mars 2016

Merci pour votre réponse! Mais là j'ai un problème car ça me prendra beaucoup de temps puisque j'ai 680 identifications (1, 2, 3, 4, 5, 6, ....., 680). Y a t-il une solution plus rapide ?
MERCI
Messages postés
25466
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bon, ben si vous dites tout on va peut être y arriver, mais d'un seul coup c'est mieux

Sur la hauteur du champ:

=SI(A1="";"";MOYENNE.SI(A:A;A1;B:B))

bonne route
Messages postés
44
Date d'inscription
jeudi 28 mars 2013
Statut
Membre
Dernière intervention
14 mars 2016

Merci beaucoup, c'est très gentil!! Vous m'avez vraiment sauvée la vie!! Merci!!
Je souhaite également faire la même chose pour la médiane que pour la moyenne!! Est ce que c'est faisable ??
Merci d'avance
Messages postés
23604
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
6 431
Bonjour à tous,

tu peux aussi faire un TCD : https://www.cjoint.com/c/CHFrUzyOdJ2
eric
Messages postés
44
Date d'inscription
jeudi 28 mars 2013
Statut
Membre
Dernière intervention
14 mars 2016

Merci beaucoup pour votre réponse !!
Messages postés
23604
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
6 431
Avec la médiane :https://www.cjoint.com/?CIbaN7cK1Rj
eric