Obtenir une liste sans doublon

Résolu/Fermé
Messages postés
18
Date d'inscription
mardi 26 août 2008
Statut
Membre
Dernière intervention
2 janvier 2019
-
Messages postés
18
Date d'inscription
mardi 26 août 2008
Statut
Membre
Dernière intervention
2 janvier 2019
-
Bonjour,

j'ai un fichier excel contien des milllier d'enregistrement, je besoin comment copier l'enrigestrement qui c repete plus de 4 fois et plus , par exemple le numero 026974040ce repete 6 fois ,un autre enrigstrement 026978960 ce repte 2 fois , je cherchr une fonction qui copier le 0269749040 sur une autre feuille
mercu d'avance

3 réponses

Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
149
Bonjour,

Voici une solution simple (si ce n'est à faire qu'une fois)

imaginons que ton tableau soit comme ca :

A : téléphone
010203
020304
010203
010203

en colonne B2 (ou une colonne vierge), tu mets cette formule :
=SI(NB.SI($A$2:$A2;$A2)>1;"";NB.SI($A2:$A$60000;$A2))
tu copies et colles cette formule sur toute ta colonne.

Tu mets un filtre sur ton tableau y compris ta colonne ou tu as ta formule.
Dans le filtre, tu déssélectionnes tout ce qui est en dessous de 4.

Tu copies tes lignes et tu les colles dans ta nouvelle feuille.
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
525
Bonjour,

Si j'ai bien compris, tu cherches à obtenir une liste sans doublon des numéros qui se répètent plus de 4 fois.
Pour reprendre la méthode de melanie1324, en colonne B2 (ou une colonne vierge), tu mets cette formule :
=NB.SI($A$2:A2;A2)
Tu effectues une copie incrémentée de cette formule sur toute ta colonne (poignée de recopie).
Tu mets un filtre sur la colonne où tu as ta formule.
Dans le filtre, tu sélectionnes tout ce qui est supérieur à 4.
Tu copies les numéros visibles et tu les colles dans ta nouvelle feuille.
Après, il ne te reste plus qu'à supprimer les doublons (Outils de données / Supprimer les doublons).
A+
Messages postés
18
Date d'inscription
mardi 26 août 2008
Statut
Membre
Dernière intervention
2 janvier 2019

merci melanie. merci gyrus ca marche c tres tres gentils