Formule pour connaître la ligne d'un chiffre

Résolu/Fermé
Signaler
Messages postés
44
Date d'inscription
lundi 1 juillet 2013
Statut
Membre
Dernière intervention
21 août 2013
-
Messages postés
44
Date d'inscription
lundi 1 juillet 2013
Statut
Membre
Dernière intervention
21 août 2013
-
Bonjour,

Microsoft Office 2007

J'ai un liste de produits chimiques sur une feuille nommé tableau. (environ 2600)

Sur une feuille deux (ajout_produit_composant), j'ai un questionnaire, lorsque je remplis une case cela me dis si ce produit est déjà présent dans le tableau.

Pour cela j'ai les formules:

Pour les produits:

=SI(NB.SI(Tableau!F:F;D8)>0;"Produit présent chez un autre fournisseur";"produit/ Non présent chez un fournisseur") Elle compare la case D8 avec la colonne F.

Pour les composants:

=SI(ESTERREUR(CHERCHE(Ajout_produit_composant!$G$5;Tableau1[ligne;[N°CAS (ou numéro MSDS)]]));0;1)

Cette formule compare le numéro cas de la case G5 pour voir s'il est contenu dans chaque ligne de la colonne numéro cas. Si oui affiche 1, si non affiche 0.

J'ai ensuite ajouter la formule:

=SI(MAX(Tableau!AI:AI)>=1;"Composant présent dans un produit de nos sous-traitants";"Composant/ Non présent")
Elle sert à faire afficher une réponse en fonction si le composant est déjà trouvé par comparaison.


J'aimerais dans ces deux cas pouvoir maintenant connaître le numéro des lignes ou sont les produits ou composants.

Par exemple:
=SI(NB.SI(Tableau!F:F;D8)>0; numéro de ligne; "")

ou

=SI(MAX(Tableau!AI:AI)>=1;numéros de lignes ;"")

J'avais eu l'idée de mettre par exemple dans une colonne les numéros de ligne, mais je sais pas non plus comment la faire afficher par la formule si le chiffre est égale à 1....

VOilà si une personne s'y connaît en synthaxe excel merci d'avance!

1 réponse

Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
149
Bonjour, tu intègres la fonction équivalence, mais ca ne te donnera que la première ligne.

=SI(NB.SI(Tableau!F:F;D8)>0; equiv(D8;Tableau!F:F;0); "")
1
Messages postés
44
Date d'inscription
lundi 1 juillet 2013
Statut
Membre
Dernière intervention
21 août 2013

C'est exactement cela, sa fonctionne pour trouver le produit et je l'ai adaptè pour le composant:

=SI(MAX(Tableau!AI:AI)>=1;EQUIV(G5;Tableau!P:P;0);"")

Dommage que cela ne puisse pas afficher tout les lignes de présence. Mais déjà super. Merci de ta rapidité melanie, cela doit être un jeu d'enfant pour toi :).

Je laisse le sujet ouvert jusqu'à demain si une personne a la solution pour afficher les autres lignes.

Merci de ton aide en tout cas!
0
Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
149
faut juste connaître certaines formules clés, equiv et index en font partie et sont en fait peu connues.
0
Messages postés
44
Date d'inscription
lundi 1 juillet 2013
Statut
Membre
Dernière intervention
21 août 2013

C'est vrai, je vais m'atteler à toute les connaître alors :).
0