Formule

Fermé
vv - 6 août 2013 à 11:02
via55 Messages postés 14041 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 février 2023 - 6 août 2013 à 11:31
Bonjour,

Je charche à faire une formule que je n'ai jamais faite.

J'ai 3 colonnes de prix d'achat (sachant que 2 de ces colonnes sont une recherche V sur une autre feuille du classeur excel), j'ai inséré une quatrième colonne sur laquelle je voudrais enregistrer la fameuse formule.

Sur chaque ligne j'ai forcément un prix d'achat dans une des 3 colonnes (jamais dans deux colonnes).

Je souhaiterais avoir le prix d'achat final dans cette quatrième colonne: si la 1ere colonne en a un, indiquer celui-ci sinon indiquer celui de la 2ème sinon indiquer celui de la 3ème.

Merci d'avance

Cdt

2 réponses

ysa17 Messages postés 10 Date d'inscription lundi 5 août 2013 Statut Membre Dernière intervention 7 août 2013 9
6 août 2013 à 11:30
Tu dois utiliser la fonction "si"
Appelons colonne 1 = A ; colonne 2 = B ; colonne 3 = C
Cela donnera la formule suivante :
=SI(A>0;A;SI(B>0;B;SI(C>0;C)))

Bien sûr, il faut qu'une seule des 3 colonnes soit remplies pour que cette formule fonctionne.

Bon courage
0
via55 Messages postés 14041 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 février 2023 2 551
6 août 2013 à 11:31
Bonjour,

Les 3 premières colonnes étant A, B et C en D la formule pourrait être :

=MAX(A1;C1)

à condition que les RECHERCHEV renvoient des 0 ou vide et non pas uneerreur si rien trouvé

sinon employer la formule :

=SI(ESTNUM(A1);A1;SI(ESTNUM(B1);B1;C1)

Cdlmnt
0