Mise en forme conditionnelle et fonction Si Excel [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
vendredi 26 juillet 2013
Statut
Membre
Dernière intervention
1 août 2013
-
Messages postés
5
Date d'inscription
vendredi 26 juillet 2013
Statut
Membre
Dernière intervention
1 août 2013
-
Bonjour,

Voici mon défi:

Je veux utiliser Excel pour mes résultats de questionnaires;

- J'ai déjà une cellule avec menu déroulant pour mes 3 différents questionnaires
- J'ai 25 questions par questionnaire
- J'évalue 4 critères différents par questionnaire

Je désir:
- Lorsque je sélectionne Questionnaire 1 dans mon menu déroulant:
- les cellules des questions 1-2-3-5-7 soit d'une couleur (relié à 1 de mes critères)
- les cellules des questions 9-11-12-18 soit d'une autre couleur, (rélié au 2e critère)
- etc.

Lorsque je change de questionnaire, les critères et les questions relié vont changer.

J'ai essayé ceci: =SI(ET($A$9="questionnaire 1";$A$13="critère 1");1;0) dans mise en forme conditionnelle, le problème c'est que je ne sais pas comment lui faire applique une couleur différente pour les questions 1-2-3-5-7 vs 9-11-12-18, etc.

Je ne sais pas si je suis assez clair, mais bon..

Merci

4 réponses

Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
165
Bonjour,
Il faut mettre une même règle 4 fois (une pour chaque questionnaire) avec 4 couleurs différentes.
Tu devrais avoir 16 règles à la fin (4 couleurs différentes pour chacuns des 4 questionnaires).

Ça ne fonctionne pas ?
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
5
Date d'inscription
vendredi 26 juillet 2013
Statut
Membre
Dernière intervention
1 août 2013
1
Bonjour Clément,

Merci pour la réponse, en fait j'ai l'impression que le problème c'est comment associé les différentes questions au différent critère.

Voici le formule que je veux créer:

Si cellule A1 = "questionnaire 1" mettre en bleu la cellule des questions # 1-2-3-4-5 (dans la sélection de 25 questions) Si A1 = "questionnaire 2" mettre en bleu la cellule des questions # 5-6-7-8
etc.

(+ 3 x pour les 3 autres critères)

J'avoue ne pas être capable de la composer correctement.

Merci,

Pascal
Messages postés
53349
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2021
15 368
Alors envoie ton fichier en mettant manuellement les couleurs à obtenir, dans les différents cas de figure.
Utilise https://www.cjoint.com/ pour créer un lien, que tu reviendras coller ici.
Messages postés
5
Date d'inscription
vendredi 26 juillet 2013
Statut
Membre
Dernière intervention
1 août 2013
1
Voici le lien: http://cjoint.com/data/0GAv5ucIbi1.htm

Wow merci beaucoup de votre aide.
Messages postés
53349
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2021
15 368
Salut.

Bien reçu ton fichier.
Malheureusement il n'est qu'à moitié renseigné, ce qui empêche d'écrire les formules conditionnelles. Il manque une plage semblable à ta plage jaune, mais qui s'appli-querait au second questionnaire.
D'ailleurs si on s'en tenait à ta phrase en B3, elle serait contradictoire avec ta demande "Lorsque je change de questionnaire, les critères et les questions relié vont changer."

Je te signale que la règle de validation des données que tu as placée en C et E contient une erreur : tu as laissé le maximum à 100 alors que l'évaluation est limitée à 10 ...
Bonjour Raymond,

Effectivement il manquait des données, car je n'ai pas encore les autres questionnaires, mais je me disais que si j'étais un mesure de trouver la réponse pour un, je serais capable pour les autres. Merci pour la règle de validation de données, c'est corrigé et avec les formules d'éric, je suis en voiture.

Bonne fin de semaine,

Pascal
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021
6 668
Bonjour,

une tentative quand même.
Mettre :
- tes titres de questionnaire dans Formules!D18:D21
- tes n° de sujet par question et par questionnaire dans 'En cours'G11:J35
(à masquer)
- ta 1ère MFC sera : =DECALER($G11;;EQUIV($A$9;Questionnaire;0)-1)=1
puis =2, =3, =4
https://www.cjoint.com/c/CGBkqtecLXU

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
Salut Eric,

Je dois m'avouer vaincu et je crois que je suis un amateur à côté de tes formules. Et, ou, si ça va mais DECALER et EQUIV, je suis perdu, mais je vais faire des recherches pour comprendre l'application de ces formules. Cependant, une chose est certaine, c'est que ça fonctionne exactement comme je l'espérais. Un gros merci et me reste à comprendre maintenant ;-)

Que veux-tu dire par: Jamais tu ne répondras à un mp non sollicité ?

Bonne fin de semaine.

Pascal, un amateur
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021
6 668
Bonjour,

EQUIV($A$9;Questionnaire;0) recherche A9 dans la plage Questionnaire et en ramène sa position. On a donc le n° de la question : 1 à 4
Le 3ème paramètre de Decaler() donne un décalage en colonne de $G11 et permet de se placer dans la colonne du questionnaire, pour y récupérer le n° de sujet de la question.

eric
Messages postés
5
Date d'inscription
vendredi 26 juillet 2013
Statut
Membre
Dernière intervention
1 août 2013
1
Merci beaucoup pour les précisions, maintenant je comprends bien les formules.

au plaisir

Pascal
Messages postés
5
Date d'inscription
vendredi 26 juillet 2013
Statut
Membre
Dernière intervention
1 août 2013
1
Je ne voudrais surtout pas abuser, mais j'essai depuis plus de 3 heures de mettre en lien le calcul de mon graphique pour chacun de mes questionnaire en A9

=+SOMME.SI(Questionnaires!$G$11:$G$35;1;Questionnaires!$C$11:$C$35) me permet de le faire pour 1 questionnaire, mais je ne suis pas capable de lier A9 pour chaque questionnaire.

https://www.cjoint.com/?0HbvaWXtIjN

Merci