"si ou si, alors"

Résolu/Fermé
Messages postés
3
Date d'inscription
jeudi 11 juillet 2013
Statut
Membre
Dernière intervention
16 juillet 2013
-
Messages postés
3
Date d'inscription
jeudi 11 juillet 2013
Statut
Membre
Dernière intervention
16 juillet 2013
-
Bonsoir,
J'ai besoin de réaliser un tableau sur excel 2007 et je ne me souviens plus comment utiliser la fonction si!
Si dans cellule (g9) , "AM" alors cellule g7 = cellule g6
Merci de votre aide!!

5 réponses

Messages postés
13352
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 janvier 2022
2 328
Bonsoir fleurine

=SI(G9="AM",G6;"") à mettre dans G7

Cdlmnt
Messages postés
55444
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 janvier 2022
17 232
Récupération de message !

Si alors
fleurine1971 - 12 juil. 2013 à 15:20 - Dernière réponse le 12 juil. 2013 à 15:27 rEVOLV3r 

Suivre - Modifier - Marquer comme résolu 

Bonjour, 

Toujours avec mon tableau excel...j'ai une colonne avec une prime à ajouter(colonne j) , une avec une prime à soustraire(colonne k) en fonction du motif indiqué (dans une colonne l); Mais le motif est indiqué : AM, CC etc...
Une idée?
Messages postés
55444
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 janvier 2022
17 232
Récupération de message !

rEVOLV3r  12 juil. 2013 à 15:27

Bonjour, 

A mettre dans votre colonne : =SI(I1="AM";montantinitial+ coloneJ;si(I1="CC;montantinitial - coloneK;SI(...)))
 
le montantinitial est le montant auquel ajouter ou retirer la prime. 

En fait le si fonctionne ainsi : 

si(une case = une condition; alors si c'est vrai on fait les transformations ici ; alors si c'est faux on fait l'autre chose ici)
 
le alors si c'est faux peut etre une autre formule SI ! comme pour votre cas. 

En espérant vous avoir aider. 
Bonne journée 

Amicalement, 
rEVOLV3r 
Messages postés
3
Date d'inscription
jeudi 11 juillet 2013
Statut
Membre
Dernière intervention
16 juillet 2013

merci de votre aide!! bonne journée
Messages postés
55444
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 janvier 2022
17 232
Salut.

Pour compléter cette solution : on peut regrouper les motifs de prime positive et de prime négative avec en M:M la formule :
=SI(OU(L:L="MM";L:L="PP";L:L="ZZ");I:I+J:J; SI(OU(L:L="AA";L:L="CC"; L:L="HH");I:I-K:K);I:I))
qu'on peut optimiser :
=I:I+SI(OU(L:L="MM";L:L="PP";L:L="ZZ");J:J; SI(OU(L:L="AA";L:L="CC"; L:L="HH");-K:K))
à adapter à ton tableau ...
Messages postés
3
Date d'inscription
jeudi 11 juillet 2013
Statut
Membre
Dernière intervention
16 juillet 2013

merci beaucoup!!!