Une formule existe pour....

Résolu/Fermé
Signaler
Messages postés
2
Date d'inscription
mercredi 3 juillet 2013
Statut
Membre
Dernière intervention
3 juillet 2013
-
Messages postés
17713
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 décembre 2021
-
Bonjour,

Je suis sur EXCEL 2010. Je souhaiterais savoir s'il existe une formule pour la situation suivante : une colonne A contient le montant de mes factures, la colonne B indique par un "o" pour oui et "n" pour non si elle a été acquittée ou pas.

Je souhaiterais pouvoir avoir dans une case (mettons C2) le montant des factures non-acquittées et dans une case (mettons C3) le montant des factures acquittées.

J'espère avoir été assez clair. Je vous remercie pas avance de votre aide précieuse.

4 réponses

Messages postés
17713
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 décembre 2021
4 861
Bonjour,

Pour o

=SOMMEPROD((B2:B20="o")*(A2:A20))

et pour n

=SOMMEPROD((B2:B20="n")*(A2:A20))

avec 2010 ou pourrait également utiliser SOMME.SI.ENS

=SOMME.SI.ENS(A2:A20;B2:B20;"o")

=SOMME.SI.ENS(A2:A20;B2:B20;"n")

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
13223
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 décembre 2021
2 293
Bonjour à tous

Mike pourquoi utiliser SOMME.SI.ENS. ? il me semble que SOMME.SI suffit dans le cas présenté

Exemple : https://www.cjoint.com/?3GdnNMA0X4y

Cdlmnt
Messages postés
17713
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 décembre 2021
4 861
Salut,

Oui bien sur également

Bonne journée
Messages postés
24
Date d'inscription
mercredi 10 avril 2013
Statut
Membre
Dernière intervention
9 mars 2014
8
Salut,

J'espère avoir compris la question mais si tu veux compter le nombre de cellule avec un "o" et celles avec un "n"

Tu peux utiliser la formule "nb.si(...)". Tu recopie donc dans C2 =NB.SI(B1:B...;"o") . Un nombre t'indiquera le nombre de o dans la colonne B.
Même opération pour le nombre de "n", il te suffit de remplacer le "o" par "n".

Espèrant avoir répondu à ta question!!!
Messages postés
2
Date d'inscription
mercredi 3 juillet 2013
Statut
Membre
Dernière intervention
3 juillet 2013

Super!!!!!!!!!!!!!!!!!!!

Merci à tous !! la formule de Mike somme.si.ens.... fonctionne à merveille!!!
Messages postés
17713
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 décembre 2021
4 861
Re,

Elles fonctionnent toutes et SOMME.SI est certainement plus simple à utiliser, comme tu n'as qu'un critère