Existe-il une formule pour calculer selon une lettre code selon

Résolu/Fermé
Signaler
Messages postés
100
Date d'inscription
samedi 20 avril 2013
Statut
Membre
Dernière intervention
10 avril 2020
-
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
-
Bonjour,

Je souhaiterais que quelqu'un puisse me venir en aide pour me proposer une formule. J'ai une lettre code dans une cellule à côté d'une date, et je souhaiterais qu'excel calcule le nombre de lettre renseignée pour chaque mois. Est-ce possible ?

Je joins un modèle d'exemple. https://www.cjoint.com/?3Gbnxpvn7at


Merci

1 réponse

Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 666
Bonjour,

Si tu rentres toutes tes dates avec les codes correspondants en feuille code, de A2 à B1000, la formule, à placer en B2, feuille activités (formule que tu peux étirer vers le bas) est :
=SOMMEPROD((code!$B$2:$B$1000=$A2)*(MOIS(code!$A$2:$A$1000)=7))

Le 7 en fin de formule pour le mois de juillet, à adapter pour les autres mois...
Messages postés
100
Date d'inscription
samedi 20 avril 2013
Statut
Membre
Dernière intervention
10 avril 2020
1
Bonjour pijaku,

Waouuuuuuh c'est exactement ce qu'il me fallait, je te remercie de m'avoir répondu pijaku ! Ce forum c'est vraiment une source de savoir, trop bien.

Encore merci
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 666
De rien.
N'hésite pas à revenir...
A+