Création de formule avec la fonction "si"

[Résolu/Fermé]
Signaler
Messages postés
87
Date d'inscription
dimanche 5 juillet 2009
Statut
Membre
Dernière intervention
12 mars 2014
-
Messages postés
87
Date d'inscription
dimanche 5 juillet 2009
Statut
Membre
Dernière intervention
12 mars 2014
-
Bonjour,

J'aimerai écrire une formule qui me calcule les conditions ci dessous :

De 0 jusqu'à 6 500 € 4,00%
Au-delà de 6 500 € jusqu'à 17 000 € 1,65%
Au-delà de 17 000 € jusqu'à 60 000 € 1,10%
Au-delà de 60 000 € 0,825%

Merci de votre aide !

3 réponses

Messages postés
26184
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 septembre 2021
6 052
Bonjour

=SI(A1="";"";SI(A1<6500;4%;SI(A1<17000;1,65%;SI(A1<60000;1,1%;0,825%))))

si vous voulez le résultat en direct par rapport à A1 remplacez les valeurs % de la formule par A1*valeur% 'ex A1*4%
et si vous voulez inclure la limite dans le % remplacez < par <=

Crdlmnt

Messages postés
26184
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 septembre 2021
6 052
.... et si vous voulez cumuler les différents taux selon les tranches, la formule est:
=SI(A1="";"";SI(A1<6500;A1*4%;SI(A1<17000;(A1-6500)*1,65%+260;SI(A1<60000;(A1-17000)*1+433,25,1%;(A1-60000)*0,825%+906,25))))
*crdlmnt
Messages postés
87
Date d'inscription
dimanche 5 juillet 2009
Statut
Membre
Dernière intervention
12 mars 2014
3
Bonjour,

Merci pour ça mais malheureusement, ça ne fonctionne pas.
J'ai essayé de corriger mais je n'y arrive pas non plus.

Le résultat doit etre 952,..
Messages postés
87
Date d'inscription
dimanche 5 juillet 2009
Statut
Membre
Dernière intervention
12 mars 2014
3
je précise que le nombre représenté par A1 est 50000.

J'ai trouvé la réponse et je vous la donne :

=(SI(B4<6500;B4*0,04;6500*0,04)+(SI(B4-6500<10500;(B4-6500)*0,0165;10500*0,0165))+(SI(B4-17000<43000;(B4-17000)*0,011;43000*0,011)+(SI(B4-60000>0;(B4-60000)*0,00825;0))))

Merci à toi Vaucluse, ton interprétation m'a ouvert d'autre piste.