Aide formule Excel

Fermé
userbear
Messages postés
529
Date d'inscription
vendredi 16 février 2007
Statut
Membre
Dernière intervention
8 avril 2019
- 16 mai 2013 à 21:57
ccm81
Messages postés
10356
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
26 juin 2022
- 17 mai 2013 à 10:11
Bonsoir à toutes et à tous;

j'ai un petit souci de formule sur Excel.
J'ai créé une formule basique sur Excel 2007 mais pour des raisons de compatibilité, je souhaiterais enregistrer mon fichier en 97-2003.
Seulement voilà, alors que ma formule marche très bien sur 2007, en version 97-2003 cela me renvoie le message
"impossible d'entrer la formule spécifiée car elle utilise plus de niveaux d'imbrication"

J'ai bien saisi le pourquoi du comment, Excel ne peut gérer que 7 niveaux d'imbrication mais je voulais savoir si :
1 : il y a possibilité d'améliorer la fonction. et là, j'ai besoin de votre génie!!
2 : il y a possibilité d'installer un patch sur les versions antérieurs d'office
3 : il y a pas grand chose à faire à part diviser la formule sur 2 cellules.

la formule est la suivante :
=SI(L50>=79;1;SI(ET(L50>=74;L50<=78);2; SI(ET(L50>=66;L50<=73);3; SI(ET(L50>=60;L50<=65);4; SI(ET(L50>=53;L50<=59);5; SI(ET(L50>=44;L50<=52);6; SI(ET(L50>=35;L50<=43);7; SI(ET(L50>=29;L50<=34);8; SI(ET(L50>=9;L50<=28);9; )))))))))


merci pour votre aide et conseils.

4 réponses

via55
Messages postés
13721
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 juillet 2022
2 443
16 mai 2013 à 23:20
Bonsoir

Pour contourner le problème des 7 imbrications maxi tu décomposes en 2 imbrications et une somme :

SI(L50>=79;1;SI(L50>=74;2;SI(L50>=66;3;SI(L50>=60;4;SI(L50>=53;5;SI(L50>=44;6) + SI(L50>=35;7;SI(L50>=29;8;SI(L50>=9;9;))))))))

Cdlmnt
0
eriiic
Messages postés
24408
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 juin 2022
7 090
Modifié par eriiic le 16/05/2013 à 23:58
Bonjour,

Pas de patch non, et il n'y en aura jamais.
Tu peux te faire un tableau de tes valeurs et ramener la réponse avec :
=RECHERCHEV(L50;$N$43:$O$48;2)

Je t'ai fait un bout de ton tableau pour t'expliquer le principe, à toi de compléter.
https://www.cjoint.com/c/CEqx3kKffKS

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
0
Raymond PENTIER
Messages postés
56319
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 juillet 2022
17 214
17 mai 2013 à 05:24
0
ccm81
Messages postés
10356
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
26 juin 2022
2 299
17 mai 2013 à 10:11
Bonjour

avec excel 2003 tu peux couper ta formule en 2, exemple

=SI(L5>=79;1;SI(L5>=74;2;SI(L5>=66;3;SI(L5>=60;4;"")))) & SI(L5>=8;SI(L5<=28;9;SI(L5<=34;8;SI(L5<=43;7;SI(L5<=52;6;SI(L5<=59;5;"")))));"")

bonne suite
0