Créer une formule avec plusieurs conditions imbriquées

Résolu/Fermé
Kty2013
Messages postés
10
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
7 juillet 2013
- 27 avril 2013 à 08:52
Kty2013
Messages postés
10
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
7 juillet 2013
- 27 avril 2013 à 09:53
Bonjour,

je voudrais créer une formule qui imbrique plusieurs conditions :

J'ai un listing de nom avec des numéros fait en 2012
Je mets à jour mon listing en rajoutant une nouvelle liste pour 2013 :
Dans cette liste je voudrais extraire les doublons (ceux inscrits en 2012 et de nouveau en 2013; )
Voici ce que j'ai fait :

-j'ai copie la liste 2013 sous celle de 2012
Fait un tri qui me permet de voir :
- les doublons (un avec numéro l'autre sans)
- les nouveaux venus (pas de numéro)
-ceux qui sont parti(un numéro mais sans doublons)
J'ai rajouté une colonne :
dans laquelle j'ai rentré cette formule :
=SI(E1>0;SI(C1=C2;"ok";"parti");"??")

Le fait est que ça me tri QUE ceux qui sont "parti" mais je ne distingue pas les autres!
D'autre part, je voudrais faire la recherche sur la plage C2:C2500 mais je n'arrive pas à le paramétrer...

merci de votre aide!
A bientôt
j'espère
Kty

2 réponses

Mike-31
Messages postés
17975
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 juin 2022
4 959
27 avril 2013 à 08:58
Salut,

Pas tout compris dans tes explications, peux tu reformuler et donner un exemple

autrement d'après ta formule =SI(et(E1>0;C1=C2);"ok";"parti")
1
Kty2013
Messages postés
10
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
7 juillet 2013

27 avril 2013 à 09:06
HELLO MIke
en fait je voudrais trouver une formule qui me permet de renseigner la cellule (dans laquell est la formule) sous c-plusieurs conditions :

Première condition : si C1=C2 plusieurs choix : 1/E1>0 (LIGNE à garder) = "OK"
2/E1=""(cellule vide; ligne à supprimer ) = "DOUBLONS"
Ensuite il me reste encore à trier donc ça nous amène à la deuxième condition :
si C1 est différent de C2 plusieurs choix : 1/ E1 >o (ligne à supprimer) ="PARTI"
2/E1=""(cellule vide; ligne à garder)

Voilà... est-ce que c'est plus clair?
0
gbinforme
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 616
Modifié par gbinforme le 27/04/2013 à 09:20
Bonjour,

Si j'ai compris, essayes cette formule qui fonctionne même sans tri :

=SI(NB.SI($C$1:$C$2500;C1)>1;SI(E1>0;"ok";"doublon");SI(E1>0;"parti";"ok-nouv"))

edit :suite ton message
Toujours zen
La perfection est atteinte, non pas lorsqu'il n'y a plus rien à ajouter, mais lorsqu'il n'y a plus rien à retirer. Antoine de Saint-Exupéry
1
Kty2013
Messages postés
10
Date d'inscription
samedi 27 avril 2013
Statut
Membre
Dernière intervention
7 juillet 2013

27 avril 2013 à 09:53
merciiiiiiiiiiiMERCIIIIIIIIIIIIIIII
ça fonctionne TIP TOP!!!!
et dire que ça faisait des heures que j'étais dessus!!! un grand grand merci
BON WE!!
0