Formule pour gros fichier excel

Résolu/Fermé
bibi51310
Messages postés
24
Date d'inscription
jeudi 14 mars 2013
Statut
Membre
Dernière intervention
23 avril 2013
- Modifié par bibi51310 le 18/04/2013 à 12:16
bibi51310
Messages postés
24
Date d'inscription
jeudi 14 mars 2013
Statut
Membre
Dernière intervention
23 avril 2013
- 22 avril 2013 à 09:01
Bonjour,

je viens ver vous car je n'arrive pas a faire ce que je veut. alors voila j'ai un fichier excel qui est extrait d'une base de donnée et je doit le traitée pour une mise en forme spécifique j'ai reproduit un exemple simple de ce que je veut obtenir dans un fichier ci joint . en première feuille c'est un exemple du fichier extrait de la base de donnée. en deuxième feuille il y a ce que j'aimerai obtenir a la fin

voila un exemple concret vaut mieux que de long discourt

https://www.cjoint.com/?0DskDRQsqPs

merci d'avance pour votre aide

3 réponses

Raymond PENTIER
Messages postés
56512
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 août 2022
17 201
Modifié par Raymond PENTIER le 18/04/2013 à 16:50
Bonjour.

Le principe est simple : en C2 mettre la formule
=RECHERCHEV(A2;Feuil1!A1:M35;2;FAUX)
En pratique il faut faire varier le N° de colonne 2 quand on va recopier la formule vers le bas ; comme ce N° de colonne en Feuil1 est identique au N° de la ligne courante en Feuil2, on écrira plutôt
=RECHERCHEV(A2;Feuil1!A1:M35;LIGNE();FAUX)
D'autre part il faut"fixer" la plage de recherche, soit en mettant des $, soit en définissant un nom pour elle, par exemple "matrice". Ainsi la formule devient
=RECHERCHEV(A2;Feuil1!$A$1:$M$35;LIGNE();FAUX)
ou
=RECHERCHEV(A2;matrice;LIGNE();FAUX)

C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
1
Raymond PENTIER
Messages postés
56512
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 août 2022
17 201
Modifié par Raymond PENTIER le 19/04/2013 à 19:19
* Dommage ! Le coup de la visualisation avec liste déroulante était bien pratique !
* RECHERCHEV avec 2 champs, non, mais avec un champ concaténé, oui !
Tu insères une colonne en C avec la formule =A:A&B:B et c'est la plage C1:O13 qui sera nommée "matrice" ; en Feuil2 la formule devient un peu plus compliquée :
=RECHERCHEV(A:A&C:C;matrice;MOD(LIGNE()-2;12)+2;FAUX)
* Pour ce qui est de répéter plusieurs fois un unicode, une date ou un affiliate, il n'y a pas 36 solutions : copier-coller ou "étirer" semblent les plus naturelles ...
https://www.cjoint.com/?CDttrIX4C1y

Bonne continuation !
C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
1
bibi51310
Messages postés
24
Date d'inscription
jeudi 14 mars 2013
Statut
Membre
Dernière intervention
23 avril 2013

22 avril 2013 à 09:01
merci a toi pour ton aide cela m'aide beaucoup a avancer dans mon fichier bonne continuation a toi aussi et encore merci pour ton aide
0
bibi51310
Messages postés
24
Date d'inscription
jeudi 14 mars 2013
Statut
Membre
Dernière intervention
23 avril 2013

18 avril 2013 à 17:29
un grand merci a toi je n'avait pas penser a la "recherchev" j'ai réussi a l'adapter sur le vrai fichier et sa fonctionne a une exception prêt : je n'arrive pas a incrémenter la ligne des eurocode mais je finirait bien par trouver une solution
0
Raymond PENTIER
Messages postés
56512
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 août 2022
17 201
Modifié par Raymond PENTIER le 18/04/2013 à 17:59
... comme de prendre une feuille différente pour chaque eurocode ?
https://www.cjoint.com/c/CDsr5da3qWL

ou mieux, utiliser une liste déroulante de cellule nommée "EUROCODE" pour sélectionner un eurocode en B3, à qui on donne le nom "eurcod" ; la formule (déplacée en E2) devient alors :
=RECHERCHEV(eurcod;matrice;LIGNE();FAUX)
https://www.cjoint.com/?CDsrZlzWvrN
0
bibi51310
Messages postés
24
Date d'inscription
jeudi 14 mars 2013
Statut
Membre
Dernière intervention
23 avril 2013

19 avril 2013 à 08:20
en faite pour 1 eurocode il faut que il soit recopié 12 fois (une foi par moi) avant de passer au suivant (en sachant que dans le fichier original il ne ce suive pas ) donc il faudrait que je trouve comment répéter 12 fois le même eurocode avant de passer au suivant.

j'essairait de te poster le fichier original car mon exemple est peu être un peu trop "light"
0
bibi51310
Messages postés
24
Date d'inscription
jeudi 14 mars 2013
Statut
Membre
Dernière intervention
23 avril 2013

19 avril 2013 à 09:56
j'ai tout de même proposer ta solution de liste déroulante a mon chef. le problème c'est que le fichier n'est pas pour visualisation mais pour entrer dans une base de donnée. il faut donc la répétition des eurocode et afficher tout les résulta sur la même feuille.

de plus mon chef vient de m'apprendre que un eurocode est associer a un pays et donc un eurocode peu avoir plusieurs pays. on peu donc oublier la recherchev (sauf si on peut rechercher sur deux champs avec). j'ai essayer la une formule avec index() et equiv() mais sans résultat concluant.

je te joint un fichier il sera peu être plus compréhensible que moi ( je n'ai pas pu te fournir le fichier original car il y a des chose que je ne peu diffuser et en plus il est assez lourd car il contient beaucoup de donnée.

https://www.cjoint.com/?0DtjVfg7HCj

en tout cas si tu arrive a trouver je te serait éternellement reconnaissant moi de mon coté je n'ai pas beaucoup avancer mais je continue a persévérer.
0