Calcul avec condition, quelle formule ? [Résolu/Fermé]

Signaler
Messages postés
396
Date d'inscription
vendredi 22 septembre 2006
Statut
Membre
Dernière intervention
8 septembre 2014
-
Messages postés
396
Date d'inscription
vendredi 22 septembre 2006
Statut
Membre
Dernière intervention
8 septembre 2014
-
Bonjour à tous,
je fais appel à vous car je me suis lancé dans un truc et je n'y parviens pas depuis plusieurs jours.

Voila mon problème:
en A1=120 A2=97
en B1=3 B2=2

A chaque valeur de B correspond un % bien précis par exemple à 1 correspond 42%, à 2 27% à 3 16% ...

Et en C j'aimerais une formule qui me fasse si B=2 alors A*27% ou si B=3 alors A*16%
Je ne sais pas si ma demande est claire ou pas. Il y a un très grand nombre de lignes donc pas faisable à la main. j'aimerai que la formule vérifie la valeur de B pour savoir avec Quel % elle doit multiplier la cellule A.
Merci de votre aide

4 réponses

Messages postés
23820
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
28 janvier 2021
6 599
Bonjour,

ou bien mettre tes % dans une table et :
=A1*RECHERCHEV(B1;$F$3:$G$20;2;FAUX)
https://www.cjoint.com/?CDqj67M2KGE

eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
553
Bonjour

Vous pouvez vous créer une table avec les valeurs
pour mon exemple
E1 = 1 F1 = 42%
E2 = 2 F2 = 27%
E3 = 3 F3 = 16%

et en C1 mettre cette formule

=A1*RECHERCHEV($B1;$E$1:$F$3;2;FAUX)
Messages postés
396
Date d'inscription
vendredi 22 septembre 2006
Statut
Membre
Dernière intervention
8 septembre 2014
21
Bonjour oui mes pourcentages sont toujours fixes.
C'est bon grace à ta formule j'ai pu faire ce que je voulais merci
Messages postés
202
Date d'inscription
lundi 21 mars 2011
Statut
Membre
Dernière intervention
8 janvier 2014
10
Bonjour

Ecris cette formule en C1 et tire ensuite


=SI(B1=3;A1*16%;SI(B1=2;A1*27%;SI(B1=1;A1*42%)))

Tes pourcentages sont toujours fixes ?
Messages postés
202
Date d'inscription
lundi 21 mars 2011
Statut
Membre
Dernière intervention
8 janvier 2014
10
Si tu changes les pourcentages crées une table avec par exemple 16% en E1 27% en E2 et 42% en E3.
Ensuite tu remplace les valeurs des pourcentage dans ta cellule par les noms des cellules.