Colorer ligne selon valeur recherchée (excel 2010)

Fermé
overdoze85 - 15 avril 2013 à 15:37
via55 Messages postés 13964 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 17 novembre 2022 - 15 avril 2013 à 16:01
Bonjour,

bonjour,

j'ai des classeurs excel avec + 2700 enregistrements. Maintenant, je fait une recherche (Ctrl+f) dans la première colonne, si la valeur existe je colore la ligne entière en jaune.

je veux faire ca en automatique : juste je lance la recherche et la ligne se colorie en jaune. j'ai déjà cherche de côté mise en forme conditionnelle mais ca pas marché



2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 284
Modifié par Vaucluse le 15/04/2013 à 15:56
Bonjour

Et pourquoi ça ne fonctionne pas avec la MFC?
si vous entrez la valeur cherchée dans une cellule hors champ (AA1 par exemple)
MFC par formule

sélectionnez le champ complet
exemple A1:Z2700
MFC pr formule:
la formule est

=$A1=$AA$1

attention aux signes $ aux bons endroits

formatez

la ligne qui contient en A la valeur de AA1 va passer en format choisi

Pour sélectionner rapidement tout le champ à traiter entrez l'adresse complète (selon l'exemple: A1:Z2700) dans la case à adresse à gauche de la barre de formule est enter;

Bien sur la formule doit correspondre à la première cellule du tableau à traiter (ici A1)
crdlmnt



Errare humanum est, perseverare diabolicum
0
via55 Messages postés 13964 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 17 novembre 2022 2 520
15 avril 2013 à 16:01
Bonjour

Ca doit marcher avec une MFC

Supposons la valeur recherchée tapée en A1 et les données allant de la ligne 3 à la ligne 3000

Selectionner toutes les lignes de 3 à 3000
MFC Nouvelle régle Utiliser une formule ...

Entrer la formule

=SI($A3=$A$1)

Avant de choisir la couleur de fond jaune et valider

Bien respecter dans la formule la références semi-absolue pour la cellule de départ de la plage de comparaison et absolue pour la cellule où se trouve la valeur recherchée


pas besoin de Ctrl f, chaque changement de la valeur en A1 entrainera une recoloration des bonnes lignes

Cdlmnt
0