Comment changer de place ses dossiers personnels [Résolu/Fermé]

Signaler
-
 Utilisateur anonyme -
Bonjour

J'ai un pc portable avec deux disque dur dont un sous Ubuntu et l'autre sous Windows. Pour pouvoir accéder a mes document de mon disque dur sous Windows directement depuis Ubuntu j'ai modifier le fichier user.dir.dir se trouvant dans /home/jordan/.config. Mais quand je vais dans dossier personnel je n'ais pas les document de mon Windows mais il sont bien présent dans le menu sur la gauche. En gros il ne sont pas présent dans /home. C'est donc pour cela que j'aimerais bien savoir comment faire pour retrouver ses fichier dans /home en sachant que je ne peut pas les copier car je n'ais pas assez de place de disque.

Merci d'avance

3 réponses

Messages postés
1053
Date d'inscription
mercredi 17 octobre 2012
Statut
Membre
Dernière intervention
17 mai 2015
158
Bonjour les modifications présentées ici http://doc.ubuntu-fr.org/tutoriel/deplacer_home ne sont pas triviales. Elles nécessitent un minimum de soin. Afin d'éviter tout problème, faites une sauvegarde de votre répertoire /home (préférablement sur un support externe, comme un disque dur USB, une clé USB ou un DVD-R par exemple) avant toute manipulation ! En cas d'erreur, il est possible que vous perdiez l'intégralité de vos fichiers importants et de votre configuration actuelle ; il est donc important d'en conserver une copie.
Utilisateur anonyme
Ce n'est pas vraiment le déplacer ce que je voudrais c'est retrouver mes fichier de mon disque dur Windows (document,images...) dans le dossier personnel de ubuntu
Messages postés
1487
Date d'inscription
mercredi 8 août 2012
Statut
Membre
Dernière intervention
18 mai 2019
211
A partir de Ubuntu, quand tu visualises Windows, il faut cliquer sur windows, puis double-cliquer (on est sur windows !) sur : "Documents and settings" puis sur dossier perso (en genéral son prénom qui est à côté de : "All users") et là on voit (enfin !) "Mes documents", il faut double-cliquer dessus !
Messages postés
23
Date d'inscription
lundi 18 mars 2013
Statut
Membre
Dernière intervention
26 mars 2013
6
Bonjour,

Crée un dossier "Windows" dans ton /home et dans /mnt ou /media :
mkdir  /home/windows
mkdir -P /media/windows


Ensuite, trouve le disque correspondant à Windows avec la commande (quelque chose comme sda1 ):
ls -l /dev/disk/by-label


Ensuite, verifie l'ID de ton utilisateur. Le premier numéro est l'uid, le deuxième, le gid
cat /etc/passwd | grep $(users)


Ajoute les lignes suivantes dans ton fstab, en remplacant sda1 par ton sda*, et les valeurs de uid et gid si nécessaire:
/dev/sda1   /media/windows   ntfs   defaults,umask=022,uid=1000,gid=1000   0   2
CheminVersMesDocuments   /home/windows   none   bind


où tu remplaces CheminVersMesDocuments.
Chez moi, c'est quelque chose comme (les espaces doivent être remplacé par \040) :
/media/windows/Documents\040and\040Settings/Prenom\040Nom/Mes\040documents


Au prochain redémarrage, ton dossier devrait être automatiquement monté.
Dis moi si tu n'as pas tout saissi... :-)
Utilisateur anonyme
J'ai trouver regardez j'ai modifier le fichier fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdb1 during installation
UUID=3e39632d-8a5b-4708-9a79-3e2d2e7e3308 / ext4 errors=remount-ro 0 1
# swap was on /dev/sdb5 during installation
UUID=e6361d93-99df-4296-b1bb-61990155c7ec none swap sw 0 0
/dev/disk/by-uuid/F666BA5F66BA1FF3 /mnt/F666BA5F66BA1FF3 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/sda2 /media/windows ntfs defaults,umask=022,uid=1000,gid=1000 0 2
/media/windows/Users/Jordan /home/windows none bind 00

Maintenant il se monte automatiquement mais comment faire pour retrouver mes fichier dans le gestionnaire de fichier dans les onglet document, image...
Messages postés
23
Date d'inscription
lundi 18 mars 2013
Statut
Membre
Dernière intervention
26 mars 2013
6
Bizarre, chez moi, ça marche sans les 0...

Pour tes dossiers :
1 - soit tu utilises la même technique (ajouter une ligne "bind" pour chaque dossier, dans fstab)
2 - soit tu ajoutes ces dossiers à tes raccourcis et supprime les anciens raccourcis

La solution 1 est la solution propre.
Utilisateur anonyme
Super Sa Marche Merci beaucoup. Maintenant je retrouve mes fichier dans le gestionnaire de fichier mais dans les onglet périphérique j'ai des périphériques se nommant document , image, musique ...) et quand je clique dessus il me dit que ce périphérique et déjà monté que faire pour ne plus qu'ils apparaissent.
Voila mon fstab :
Merci

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdb1 during installation
UUID=3e39632d-8a5b-4708-9a79-3e2d2e7e3308 / ext4 errors=remount-ro 0 1
# swap was on /dev/sdb5 during installation
UUID=e6361d93-99df-4296-b1bb-61990155c7ec none swap sw 0 0
/dev/disk/by-uuid/F666BA5F66BA1FF3 /mnt/F666BA5F66BA1FF3 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/sda2 /media/windows ntfs defaults,umask=022,uid=1000,gid=1000 0 2
/media/windows/Users/Jordan /home/windows none bind 00
/home/windows/Music /home/jordan/Musique none bind 02
/home/windows/Vidéos /home/jordan/Vidéos none bind 02
/home/windows/Pictures /home/jordan/Images none bind 02
/home/windows/Documents /home/jordan/Documents none bind 02
/home/windows/Downloads /home/jordan/Téléchargements none bind 02
Messages postés
23
Date d'inscription
lundi 18 mars 2013
Statut
Membre
Dernière intervention
26 mars 2013
6
Pour le problème que tu cites, je te renvois ici : http://forum.ubuntu-fr.org/viewtopic.php?pid=931352#p931352

Une dernière chose : il est souvent plus fiable d'utiliser la syntaxe UUID=********* plutôt que /dev/sda* pour décrire un disque (la première colonne de fstab). La commande çi-dessous te donner l'association entre les block devices et les UUID :
ls -l /dev/disk/by-uuid

Si tu as la foi de le changer dans ton fstab...

C'était un peu long mais on a réussi :-)
Utilisateur anonyme
Merci beaucoup pour votre aide