Insérer un sourire ou une grimace dans une cellule excel (MFC) [Fermé]

Signaler
Messages postés
3
Date d'inscription
samedi 16 mars 2013
Statut
Membre
Dernière intervention
16 mars 2013
-
Messages postés
3
Date d'inscription
samedi 16 mars 2013
Statut
Membre
Dernière intervention
16 mars 2013
-
Bonjour,

Je souhaite en fonction du résultat d'une cellule (condition qui dit "OK" ou "à revoir") insérer dans cette même cellule OU une cellule à proximité un bonhomme qui sourit ou un autre qui fait la grimace. Pouvez-vous me dire comment faire, sachant que je ne suis pas une pro de la VBA. Merci de vos éclairages. Pattoche33


3 réponses

Messages postés
12932
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2021
2 128
Bonjour

pas besoin de macro

supposons choix OK ou au revoir en B3
formule à mettre dans cellule à côté en C4
=SI(B3="OK";"J";"L")
et choisir Wingdings comme police de C4
Affichera sourire si OK et grimace sinon

Cdlmnt
8
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
25817
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 784
Bonjour

sans passer par VBA:

une formule dans le cellule recevant l'affichage selon le résultat de A1 (à adapter)=SI(A1="OK";"J";SI(A1="A revoir";"L";"K"))
et formatez cette cellule avec la police:
ZapfDingbats

elle vous renverra un Smiley triste si A revoir, souriant si OK et normal si rien de tout ça

Vous pouvez bien sur assortir cette cellule d'une MFC en couleurs variables selon sa valeur, par exemple:
J en vert , K en bleu et L en rouge

crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
3
Date d'inscription
samedi 16 mars 2013
Statut
Membre
Dernière intervention
16 mars 2013

Je n'ai pas trouvé la police ZapfDingbats mais çà marche bien avec Wingdings
avec la MFC c'est encore mieux. Merci pour votre aide et bon après midi.
Messages postés
3
Date d'inscription
samedi 16 mars 2013
Statut
Membre
Dernière intervention
16 mars 2013

C super et çà me va bien, merci !!!