Déplacer cellules négatives dans colonne voisine [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
vendredi 15 mars 2013
Statut
Membre
Dernière intervention
15 mars 2013
-
Messages postés
502
Date d'inscription
mercredi 6 mars 2013
Statut
Membre
Dernière intervention
16 janvier 2016
-
Bonjour,
Ma banque fournit ses relevés du net en Excel à la demande, mais les débits et les crédits sont sur la même colonne.
je voudrais -simplement-- déplacer les cellules avec chiffres négatifs dans une autre colonne qui serait celle du "débit", mais sur la même ligne.
merci !
(avec la recherche des cellules contenant (-) et un copié-collé, la copie aligne les chiffres sans reproduire les blancs, ils ne sont donc plus sur la ligne de leur intitulé).
c'est un vieil excel (97 ?)
Merci



2 réponses

Messages postés
502
Date d'inscription
mercredi 6 mars 2013
Statut
Membre
Dernière intervention
16 janvier 2016
187
Bonjour,
je pense qu'il faut que tu insères 2 nouvelles colonnes (une pour les débits, une pour les crédits), après la colonne de tes crédits/débits.
Si ta colonne crédit/débit est B, alors en C pour avoir uniquement les débits, tu te sers de la formule =SI(B8<0;B8;"")
et pour la colonne des crédits en D tu te sers de la formule =SI(B8>0;B8;"")
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
vendredi 15 mars 2013
Statut
Membre
Dernière intervention
15 mars 2013

merci ! mais si je comprends bien il faut refaire la manip pour chaque cellule : la tienne marche pour la B8 seulement ?
comment faire pour toute la colonne B ?
je sens que je progresse..
Messages postés
502
Date d'inscription
mercredi 6 mars 2013
Statut
Membre
Dernière intervention
16 janvier 2016
187
ah, non donc tu prends ces formules pour le haut de ta colonne. Ensuite pour pour la premiere cellule ou tu as marqué la formule, tu te place sur cette cellule, et en bas a droite de la cellule, il y a un petit carré, tu pointes le petit carré avec la souris, tu maintiens le clic droit, et tu descends jusqu'au bas de ta colonne. et tu fais pareil pour l'autre colonne après
Messages postés
4
Date d'inscription
vendredi 15 mars 2013
Statut
Membre
Dernière intervention
15 mars 2013

ça y est j'ai pigé, merci et bravo (avoue que l'aide Excel est imbittable !)
et ça marche au poil grace toi

@+?
Messages postés
502
Date d'inscription
mercredi 6 mars 2013
Statut
Membre
Dernière intervention
16 janvier 2016
187
imbittable ???? vive les labsus révélateur
Messages postés
25768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 janvier 2021
5 740
Bonjour
je ne connais que sur 2007 je ne sais donc pas si ça fonctionne sur 97
essayez:
sélectionner la colonne
Outil/ données/ convertir/délimité
choisir le séparateur : "autre" et le signe -
"terminer"
et les négatifs changent de colonne

crdlmnt
Messages postés
4
Date d'inscription
vendredi 15 mars 2013
Statut
Membre
Dernière intervention
15 mars 2013

merci Vaucluse !
ça marche...si on veut ! mais bizarement, c'est les chiffres POSITIFS qui sont mutés dans la colonne choisie !
et si je mets +...c'est la totalité qui mute
la réponse du _gui_gui est plus compliquée mais fonctionne.
EN tous cas merci d'avoir essayé
Messages postés
25768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 janvier 2021
5 740
Vous avez une solution et c'est l'essentiel. Pour info, je teste et ça fonctionne, mais je pense que le problème vient du copier coller qui perturbe le format de vos valeurs.
Si par hasard vous voulez aller plus loin dans ce système, essayez:
entrez 1 dans une cellule hors champ
copier là
sélectionnez votre colonne de valeur / clic droit / collage sépcial/ Multiplication
et convertissez après cette opération.
crdlmnt