Phpmyadmin HTTP/1.1" 302 sans déplacement de fichier

Résolu
Bonjour,

Depuis que j'ai sécurisé phmyadmin et quand je me log, j'ai au moins 1 fois par semaine l'erreur suivante (en localhost avec XAMPP) sans que je puisse faire quoi que ce soit (mis à part de restaurer ma sauvegarde):

phpMyAdmin - Erreur

Erreur lors du démarrage de la session, veuillez vérifier les erreurs

indiquées par PHP ou dans le fichier témoin du serveur web, et configurer

PHP correctement.

Dans mon fichier log: HTTP/1.1" 302. (fichier déplacé)

Restaurer ne me prends que 3 ou 4 minutes mais, je préfèrerai savoir le pourquoi de cette erreur.

5 réponses

  1. Contributeur
    Un HTTP 302 c'est pas très descriptif. Phpmyadmin doit se plaindre bien plus normalement, tu n'as probablement pas assez cherché. Regarde bien TOUS les logs.
    1. En fait dans le error.log, il me trouve ça:

      httpd.exe: Syntax error on line 508 of G:/PROGRAMMES DE TBA/xampp/apache/conf/httpd.conf: Include directory 'C:/xampp/alias' not found

      Pourtant cela fonctionne bien et mon alias est dans:

      include "G:/PROGRAMMES DE TBA/xampp/alias/*"
      1. Contributeur
        Oh non je t'en prie, ne me dis pas que tu as mis des espaces là ou tu as installé ton serveur web! En général c'est une TRES mauvaise idée. C'est peut-être à cause de ça que ça ne marche pas.
        1. Contributeur
          Les espaces dans le chemin d'accès sont peut-être la source du problème.
          Mais je doute que déplacer tout un serveur web à la racine corrige tout: il faut le reconfigurer et changer les chemins d'accès s'ils sont déjà écrits dans des fichiers de config.
          Si le serveur peut être désinstallé puis réinstallé à la racine, la config devrait être correcte.
          1. C'est un fait car j'avais des problèmes avec le perl.conf et le httpd.conf sans pouvoir résoudre ceux du perl.conf alors j'ai réinstallé.