Simplifier formule Somme.si.ens qui pourrait avoir un OU?

Résolu/Fermé
Signaler
-
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
-
Bonjour,
Je suis a rédigé une formule Somme.si.ens et engros ce que je veux dire est:
- Addition une cellule si la cellule a est égale à b ou c ou d, en gros c'Est ca.

Pour l'instant voici la formule que j'ai:

=SOMME.SI.ENS('82D247'!$D$9:$D$31;'82D247'!$A$9:$A$31;Y$9)+SOMME.SI.ENS('82D247'!$D$9:$D$31;'82D247'!$A$9:$A$31;Y$10)+SOMME.SI.ENS('82D247'!$D$9:$D$31;'82D247'!$A$9:$A$31;Y11)+SOMME.SI.ENS('82D247'!$D$9:$D$31;'82D247'!$A$9:$A$31;Y$12)

En fait, je fais 4 fois la même fomule, mais en changeant le dernier critère.

Merci de m'aider!

1 réponse

Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 185
Bonjour
avec ce code je ne pense pas mais essayez avec:
=SOMMEPROD(( '82D247'!$A$9:$A$31=Y$9)+('82D247'!$A$9:$A$31=Y$10)+('82D247'!$A$9:$A$31=Y$11)+('82D247'!$A$9:$A$31=Y$12))*('82D247'!$D$9:$D$31))

attention aux parenthèses.
Crdlmnt
0
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 590
Bonjour Vaucluse,

J'avais pensé comme toi, mais le résultat n'est pas le même ?
0
Effectivement, malheuresement le résultat n'est pas le même.
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 185
Salut GB

Tu as raisonj

C'est un problème de nombre de parenthèses dans ma proposition, en fait

=SOMMEPROD((( '82D247'!$A$9:$A$31=Y$9)+('82D247'!$A$9:$A$31=Y$10)+('82D247'!$A$9:$A$31=Y$11)+('82D247'!$A$9:$A$31=Y$12))*('82D247'!$D$9:$D$31))

Il en faut 3 derrière SOMMEPROD et 2 à la fin.


Sinon, Excel en enlève une à la fin et ne fait que compter le nombre de codes sans additionner la colonne SOMME

là je viens de tester et ça fonctionne.

Bien cordialement
0
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 590
Bonjour Vaucluse,

et pour les parenthèses tu peux regagner celles que tu avais oublié car tu n'en as pas besoin pour la plage totalisée :

*'82D247'!$D$9:$D$31) 
0
Wow ca marche! Vous etes malades! MERCI!
0