Formule Excel avec référence circulaire

Résolu/Fermé
elisa78945 - 15 févr. 2013 à 11:43
fichier62 Messages postés 45 Date d'inscription jeudi 18 décembre 2008 Statut Membre Dernière intervention 6 novembre 2013 - 15 févr. 2013 à 17:03
Bonjour,

voici mon souci :

Nombre de voiture vendues dans A1
Si A1 = zéro alors pas de frais de dossier (150 euros)
Si A1>zéro alors frais de dossier de 150 euros (quelque soit le chiffre en A1)
Les frais de dossier se trouvent en C1

Ma formule : =si(A1=0;C1=0;150)
Cela ne fonctionne pas :
Et Excel me « parle » de référence circulaire
Pouvez-vous m'aider svp ?
Merci
Lisa

5 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
Modifié par Vaucluse le 15/02/2013 à 11:45
Bonjour
vous ne pouvez pas écrire en C1 la condition SI(C1=0 . La référence circulaire est là!
Et de surcroît elle est inutile!
Ecrivez:
=SI(A1>0;150;0)
et ça devrait suffire
Crdlmnt
Errare humanum est, perseverare diabolicum
1
via55 Messages postés 13965 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 27 novembre 2022 2 520
15 févr. 2013 à 11:48
Bonjour

La formule étant en C1 c'est normal puisque tu mets C1=0 dans la formule

LA formule correcte serait
=SI(A>0;150;0)

Cdlmnt
0
chossette9 Messages postés 4239 Date d'inscription lundi 20 avril 2009 Statut Contributeur Dernière intervention 12 septembre 2014 1 307
15 févr. 2013 à 11:49
Bonjour,

=SI(A1=0;0;150) fonctionnera mieux. Le soucis est que vous indiquiez C1=0 dans la formule, ce qui vous ressort une référence circulaire.

Cordialement.
0
merci à tous pour vos réponses
bonne fin de journée
Elisa
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
fichier62 Messages postés 45 Date d'inscription jeudi 18 décembre 2008 Statut Membre Dernière intervention 6 novembre 2013
15 févr. 2013 à 17:03
merci à tous super !
Bonne journée
0