Comment traduire cet algorithme en formule Excel?

[Résolu/Fermé]
Signaler
-
 starter01 -
Bonjour à la communauté!

J'aimerais savoir, SVP, comment cet algorithme doit être écrit en formule Excel. Je tourne en bourrique depuis plusieurs heures... Le voici:


Si (B2=A1) ET (C2=1) alors D2=0
Sinon
Si (B2=A1) ET (C2=2) alors D2=3
Sinon
Si (B2=A1) ET (C2=3) alors D2=4
Sinon
Si (B2=A1) ET (C2=4) alors D2=5

Sinon
Si (B2<>A1) ET (C2=1) alors D2=0
Sinon
Si (B2<>A1) ET (C2=2) alors D2=-1
Sinon
Si (B2<>A1) ET (C2=3) alors D2=-2
Sinon
Si (B2<>A1) ET (C2=4) alors D2=-5


En somme (attention, ce n'est pas une somme... [rires]), La case D2 doit contenir une des valeurs indiquées (positive ou négative) selon d'une part que A1 égal à B2 (réponse correcte de l'élève) OU A1 différent de B2 (réponse incorrecte de l'élève) ET un indice de valeur 1, 2, 3, ou 4 qu'il donne a sa réponse.

Jusqu'ici je n'y parviens pas et votre aide me serait précieuse.
D'avance MERCI !

6 réponses

Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 567
J'ai mis en A1, B1 et C1 les données à introduire:

=SI(A1=B1;SI(C1=1;0;SI(C1=2;3;SI(C1=3;4;5)));SI(C1=1;0;SI(C1=2;-1;SI(C1=3;-2;-5))))
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
2496
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
6 octobre 2021
1 000
Bonjour,
Une autre idée:
=SI(B2=A1;CHOISIR($C$2;0;3;4;5);CHOISIR($C$2;0;-1;-2;-5))
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
Bien vu, Tongtong,
+1
Je m'empresse de vous dire Merci, Bruce Willix!
Déjà je n'ai plus de message d'erreur... D2 n'affiche pas la valeur correcte mais sans doute vous avez tapé pour me mettre sur la piste. je vais donc utiliser votre équation pour y revoir les les indices.

Je reviens sous peu si ça marche, sinon je reviens un plus plus tard, signe que je sèche...
ça marche! C'est extraordinaire! Ouf, quel soulagement, encore Merci Bruce (je reviendrai...)

Votre équation (la première) devient donc (dans ma première ligne utile):

=SI(A2=B2;SI(C2=1;0;SI(C2=2;3;SI(C2=3;4;SI(C2=4;5))));SI(C2=1;0;SI(C2=2;-1;SI(C2=3;-2;SI(C2=4;-5)))))

Merci aussi pour votre 2e équation. Dès que je retrouve mes esprits, car là je suis vraiment content, je vais bien étudier ces 2 mises en équations. Leur complexité est dans leur simplicité apparente. En effet, entre tourner en rond avec un algorithme (écrit par moi-même en 45') et sécher pendant des heures pour la mise en équation dans Excel (et SANS y parvenir) me donne bien à réfléchir.... Merci, merci beaucoup, Bruce.
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
La 2° c'est Tongtong: Merci pour lui puisque tu le snobes
Messages postés
2496
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
6 octobre 2021
1 000
Bonjour michel_m,
Et merci pour la distinction, mais ce n'est pas grave bientôt ses élèves apprendront que de la pluralité naît l'excellence!
...hum.. pas en 45' en 45'' je voulais dire. Bon, autant le dire car j'avais l'air d'être plutôt fier en disant 45 minutes...
Grand merci à TongTong et mille excuses d'avoir confondu (disons avoir "fondu") Bruce et TongTond (remarque de pijaku qui a attiré mon attention, merci à lui aussi).