Formule pour calculer un nombre de salarié a une date

Résolu/Fermé
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013
- 30 janv. 2013 à 10:05
Mike-31
Messages postés
18013
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 août 2022
- 4 févr. 2013 à 14:32
Bonjour à tous,

Je reviens vers vous, toujours pour un renseignement sur une formule excel.

Nous sommes actuellement entrain de remplir les bordereaux d'organisme payeur des formations. Et une question nous est posée : "indiquez l'année ou le seuil de 10 salariés a été atteint pour la première fois".

Quelqu'un pourrait-il m'expliquer comment effectuer ce genre de formule sans avoir à compter manuellement ... ?

Voici le fichier sur lequel nous pouvons nous baser : https://www.cjoint.com/c/CAEkdqgwZ36

Merci pour votre aide :)

Laure



10 réponses

Mike-31
Messages postés
18013
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 août 2022
4 965
30 janv. 2013 à 10:29
Salut,

pas tout compris, tu veux savoir le nombre de personnes inscrite dans ta colonne C qui était présente une année donnée en tenant compte des dates d'entrée colonne N et sortie colonne Q

c'est cela ?
0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

30 janv. 2013 à 11:17
Salut Mike-31,

Merci pour ta réponse :)

Oui voila, en résumant c'est un peu ça.

En fait il y a plusieurs seuils, si l'on dépasse les 10 salariés la prise en charge de la formation sera différente. Aujourd'hui nous sommes 15 salariés.

L'organisme souhaite cependant savoir en quelle année nous avons dépasser les 10 salariés.

Je ne sais pas si c'est plus clair ?

N'hésite pas si tu souhaites plus d'explications !!

Laure ;)
0
Mike-31
Messages postés
18013
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 août 2022
4 965
30 janv. 2013 à 11:33
Re,

Teste cette formule pour voir, en I2 saisi l'année exemple 2008

=SOMMEPROD((ANNEE(N10:N46)<=I2)*(ANNEE(Q10:Q46)>=I2)*(C10:C46<>""))

0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

Modifié par laureal le 30/01/2013 à 11:45
Merci Mike-31 :)

Pourrais tu par contre m'expliquer la formule en "français" ?

Car en 2008 je trouve un total de 13, et lorsque je modifie la date forcément le total change, pour finir à 2 en 2013 : https://www.cjoint.com/c/CAElTFofCQ3

(Au cas ou je vais peut être ré-expliquer, je cherche à savoir en quelle année, nous sommes arrivés à au moins 10 salariés)

En tout cas merci beaucoup pour ton aide :)

Laure
0
Mike-31
Messages postés
18013
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 août 2022
4 965
30 janv. 2013 à 13:18
Re,

=SOMMEPROD((ANNEE(N10:N46)<=I2)*(ANNEE(Q10:Q46)>=I2)*(C10:C46<>""))

SOMMEPROD est une fonction Excel qui permet de faire la somme ou de compter le contenu d'une plage en fonction de critères
ici les critères dates, on va chercher parmi les dates N10 à N46 la date de référence saisie en I2 est antérieur ou égale aux dates rencontrées
ANNEE(Q10:Q46)>=I2
idem pour la plage Q10 à Q46 mais cette fois inférieure ou égale à I2, ce qui veut dire que si la date de référence en I2 se trouvent entre ces deux bornes le test est positif reste plus qu'à compter le nombre de valeur sur la plage C10 à C46 répondant aux critères
0
via55
Messages postés
13799
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
8 août 2022
2 467
30 janv. 2013 à 17:12
Oui Mike MAIS Il y a un problème : celui de ceux qui sont toujours en poste et dont l'année de sortie renvoyée par la cellule vide est 1900!!

En fait pour avoir les salariés présents une année X (ce qui est demandé pour connaitre quand le seuil aura été dépassé) il faut comptabiliser tout ceux qui sont sortis après (soit année X+1) + ceux qui ne sont jamais sortis (soit valeur année sortie retournée >2007

Voilà donc la formule

=SOMMEPROD((ANNEE(N10:N46)<=I2)*(ANNEE(Q10:Q46)>=(I2+1))*(C10:C46<>"")) + SOMMEPROD((ANNEE(N10:N46)<=I2)*(ANNEE(Q10:Q46)<2007)*(C10:C46<>""))

1ere partie comptabilise toutes les cellules C rensignées (<>"") par les cellules correpondantes d'année d'entrée<= à l'année choisie en I2 par les cellules d'année de sortie >= à l'année +1 soit SALARIES SORTIS APRES ANNEE X
2eme partie comptabilise de la mm manière ceux dont la date de sortie est < 2007 c à d en fait ceux qui ne sont jamais sortis puis qu'aucune date de sortie renvoie 1900 comme année (c comme ça !)soit SALARIES TOUJOURS EN POSTE

L'addition des 2 donne bien les salariés présents tout au long de l'année choisie

Cordialement
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Mike-31
Messages postés
18013
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 août 2022
4 965
Modifié par Mike-31 le 30/01/2013 à 19:05
Salut,

Ah oui exact et dans ce cas il est également possible de tester comme cela

=SOMMEPROD((ANNEE(N10:N46)<=I2)*(ANNEE(Q10:Q46)>=(I2+1))*(C10:C46<>"")) + SOMMEPROD((ANNEE(N10:N46)<=I2)*(Q10:Q46="")*(C10:C46<>""))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

31 janv. 2013 à 12:10
Bonjour Mike et Via :)

Désolée de ne pas avoir répondu plus tôt mais je n'ai pas eu le temps et je n'ai pas non plus le temps de regarder la formule cet aprèm, donc je regarderais ce soir !

En tout cas merci à vous deux pour votre implication !

Je reviens vers vous dès demain :)

Bonne journée.

Laure :)
0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

1 févr. 2013 à 10:22
GENIAL !!

Ca fonctionne !! Vraiment merci à tous les deux pour votre aide !!!

Très gentil de votre part, encore merci !!

Très bonne journée :)

Laure
0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

4 févr. 2013 à 11:38
Hello :)

Excusez moi mais je reviens vers vous !! J'avais vérifié que certaines années, mais en testant avec l'année 2008, la formule m'indique 11 salariés présents, alors que si on compte manuellement, on en trouve 14.

Pourriez vous me dire d'où vient cette erreur ? https://www.cjoint.com/?CBelLZTiYCD

Merci pour vos retours :)

Très bonne journée.

Laure.
0
eriiic
Messages postés
24422
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2022
7 100
4 févr. 2013 à 11:59
Bonjour,

Si les critères n'ont pas changés j'en compte bien 11.
Fourni un autre tableau en surlignant tes 14.

Sinon tu peux simplifier ta formule :
=SOMMEPROD((ANNEE(N10:N46)<=I2)*((ANNEE(Q10:Q46)>=(I2+1))+(Q10:Q46=""))*(C10:C46<>""))

eric

0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

4 févr. 2013 à 12:09
Bonjour Eric,

Merci pour ton intérêt tout d'abord !

J'ai surligné en jaune les 14 salariés présents en 2008. https://www.cjoint.com/?CBemjr0u46p

Bon j'imagine que tu t'en étais douté mais au cas ou, lorsqu'il n'y a pas de date de sortie cela signifie que le salarié est toujours présent.

:)

Laure
0
eriiic
Messages postés
24422
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
8 août 2022
7 100
Modifié par eriiic le 4/02/2013 à 12:34
Tu comptais ANNEE(Q10:Q46)>=(I2+1) et là tu comptes ANNEE(Q10:Q46)>=I2
Faut savoir...
Parce que tu le vaux bien :
=SOMMEPROD((ANNEE(N10:N46)<=I2)*((ANNEE(Q10:Q46)>=I2)+(Q10:Q46=""))*(C10:C46<>""))
mais ça fait 15 avec la ligne 42 que tu as oubliée.

eric
0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

4 févr. 2013 à 13:38
Oh yeah :)

Super !!

Merci encore pour ton aide !!!

Laure )
0
laureal
Messages postés
62
Date d'inscription
vendredi 14 septembre 2012
Statut
Membre
Dernière intervention
29 avril 2013

4 févr. 2013 à 14:15
... Bon décidément je ne vais pas y arriver... Lorsque l'on remet 2012 par exemple, cela me met 19 salariés. https://www.cjoint.com/?CBeopJaYNg3

Désolée si je vous fais perdre votre temps...
0
Mike-31
Messages postés
18013
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 août 2022
4 965
Modifié par Mike-31 le 4/02/2013 à 14:33
Salut,

Mais c'est normal, si colonne Q est vide et la colonne N contient une date, c'est que l'agent est encore dans les effectifs, soit 15 + 4 sorties en 2012 ce qui nous fait bien 19
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0