Moyenne horaire avec des dates differentes sous excel

Résolu/Fermé
Messages postés
41
Date d'inscription
mercredi 4 février 2009
Statut
Membre
Dernière intervention
16 avril 2013
-
Messages postés
41
Date d'inscription
mercredi 4 février 2009
Statut
Membre
Dernière intervention
16 avril 2013
-
Bonjour

Je souhaite faire la moyenne horaire d'une colonne avec des dates differentes. Par exemple :

03/1/13 12:00
04/01/13 8:00
08/01/13 16:00
09/1/13 9:00
10/1/13 8:30

Y a t il une formule qui calcule cette moyenne en ne retenant que les données horaires, soit 12:00 / 8:00 / 16:00 / 9:00 / 8:30 ??

De manière générale, Comment sépares t on les données date et heure dans excel ?

Ne sachant pas, pour l'instant et dans le cas présent, je crée deux colonnes une pour la date oune pour l'heure. Je prefererais synthethiser mon tableau, du moin si c'est possible

Merci d'avance

Vince

4 réponses

Messages postés
24291
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
7 034
Bonjour,

excel stocke les dates-heures sous forme d'un nombre décimal.
La partie entière est le nombre de jour depuis le 31/12/1899 (1=1/1/1900), en se méfiant que n'est bon qu'à partir du 01/03/1900 vu qu'excel considère que 1900 est bissextile (comme quoi avoir les meilleurs ingé de la planète ne permet pas tout...)
La partie décimale est l'heure en fraction de jour (0.25 = 6:00)
Partie décimale : =mod(A1;1)
mettre le format heure voulu, ou le format personnalisé [h]:mm si on veut afficher un nombre d'heure > 24

Moyenne :
=MOYENNE(MOD(A1:A5;1))
formule matricielle à valider avec shift+ctrl+entrée
et mettre le format désiré

eric


Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
Messages postés
41
Date d'inscription
mercredi 4 février 2009
Statut
Membre
Dernière intervention
16 avril 2013
1
Ok, ça fonctionne bien

par contre s'il ya des cellules vides, on dirait que ça prend quand même en compte une valeur

j'ai fait l'essai avec
A1 = 03/1/13 11:15
A2 = VIDE
Résultat = 5:37

Sais tu si la formule peut ne prendre en compte la cellule dans le calcul que s'il y a une valeur d'inscrite à l'intérieur ?

Merci pour ton aide

Vince
Messages postés
24291
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
7 034
Re,

=SOMME(MOD(A1:A5;1))/NB(A1:A5)
formule matricielle à valider avec shift+ctrl+entrée

eric

Messages postés
41
Date d'inscription
mercredi 4 février 2009
Statut
Membre
Dernière intervention
16 avril 2013
1
Ok parfait

ça marche

Merci encore