Combiner deux conditions excel

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
vendredi 11 janvier 2013
Statut
Membre
Dernière intervention
11 janvier 2013
-
Messages postés
6
Date d'inscription
vendredi 11 janvier 2013
Statut
Membre
Dernière intervention
11 janvier 2013
-
Bonjour,
j'ai grand besoin de votre aide je ne trouve pas donc voilà j'ai cette formule la :
=SI('Suivi arrêts B3'!BE6=1;SI('Suivi arrêts B4'!BE6=1;SI('Suivi arrêts P5'!BO6=1;SI('Suivi arrêts P7'!BO6=1;SI('Suivi arrêts P8'!BO6=1;SI('Suivi arrêts P9'!BO6=1;SI('Suivi arrêts P11'!BO6=1;"fait";"non");"non");"non");"non");"non");"non");"non")
et celle la :
=SI(ESTVIDE('Suivi arrêts P11'!BO6);SI(ESTVIDE('Suivi arrêts P9'!BO6);SI(ESTVIDE('Suivi arrêts P8'!BO6);SI(ESTVIDE('Suivi arrêts P7'!BO6);SI(ESTVIDE('Suivi arrêts P5'!BO6);SI(ESTVIDE('Suivi arrêts B4'!BE6);SI(ESTVIDE('Suivi arrêts B3'!BE6);"ok";"non");"non");"non");"non");"non");"non");"non")

les deux formules fonctionnent mais toutes seule et je voudrais les liées . Merci de votre aide !!


4 réponses

Messages postés
17550
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 septembre 2021
4 741
Salut,

Je doute fort que tes formules fonctionnent correctement, mis à part cela oui il est possible de les imbriquer mais avant je préfairerais les simplifier.
explique par plage ce que tu espères comme résultat exemple pour
SI('Suivi arrêts B3'!BE6=1 qui devrait être SI('Suivi arrêts'!B3:BE6=1 que faut il faire
idem pour les autres conditionnelles
SI('Suivi arrêts'!B4:BE6=1
etc
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 898
Bonjour,

Si tes feuilles se succèdent et sont regroupées :
=SI(SOMME(Feuil1:Feuil2!A1)+SOMME(Feuil3:Feuil6!B1)=6;"fait";"non")
et
=SI(NBVAL(Feuil1:Feuil6!A1)=6;"ok";"non")
devraient te retourner le bon résultat (avec les bons noms et références).

Ensuite pour combiner tu peux, mais tu ne précises pas l'ordre.
QSi les même conditions sont remplies afficher fait ou ok ?
Si la 1ére partie l'est et pas la 2nde ou bien l'inverse il faut afficher quoi dans ces 2 cas ? non ?

eric
Messages postés
6
Date d'inscription
vendredi 11 janvier 2013
Statut
Membre
Dernière intervention
11 janvier 2013

Les deux conditions soit remplis faut afficher fait. dans toutes les feuilles je dois prendre une valeur et cette valeur . Et si cette valeur est égale a 1 ou cellule vide. Alors a la dernière feuille il faut afficher 'fait'
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 898
Bon, tu n'as pas l'air décidé à chercher à simplifier tes formules...
Si tu es sur 2003 il faut utiliser une (des) cellule intermédiaire car tu es limité à 7 imbrications.
Sur 2010 tu imbriques normalement.

eric
Messages postés
6
Date d'inscription
vendredi 11 janvier 2013
Statut
Membre
Dernière intervention
11 janvier 2013

il me le souligne le suivi du 'suivi arrets b4'
Messages postés
6
Date d'inscription
vendredi 11 janvier 2013
Statut
Membre
Dernière intervention
11 janvier 2013

Suivi arret B3 = B3 = une nouvelle feuille pas une celulle
Messages postés
17550
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 septembre 2021
4 741
Re,

Je ne comprends pas ce que tu veux dire,
si feuille Suivi arrêts cellule B3=1 que faut il faire
Messages postés
6
Date d'inscription
vendredi 11 janvier 2013
Statut
Membre
Dernière intervention
11 janvier 2013

B3 n'est pas le nom d'une cellule mais d'une feuille. Si mes formules marche bien séparément
..
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 898
C'est deux point (:) et pas point-virgule(;) pour séparer les noms des feuilles.
Et les simples cotes doivent encadrer les 2 noms des feuilles.

=SOMME('Feuil1:Feuil6'!A1) va ta faire la somme de A1 de toutes les feuilles comprises entre Feuil1 et Feuil6 (celles dont tu vois les onglets entre ces 2 feuilles)
=NBVAL('Feuil1:Feuil6'!A1) te donnera le nombre de saisies en A1 sur ces feuilles

Et on ne sait toujours pas ta version pour savoir si tu es limité à 7 imbrications de fonctions.

eric
Messages postés
6
Date d'inscription
vendredi 11 janvier 2013
Statut
Membre
Dernière intervention
11 janvier 2013

ok j'ai fais ce que vous m'avez dis . Sa marche, mais moi des fois même si la case n'est pas rempli je veux que sa le renseigne sur ma derniére feuille et que sa me mette quand même ok.
j'ai la version 2003
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 898
Re,

voir également ma suggestion du post 3
eric