Addition de 2 formules dans 1 seule cellule [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
jeudi 13 décembre 2012
Statut
Membre
Dernière intervention
5 janvier 2013
-
Messages postés
8
Date d'inscription
jeudi 13 décembre 2012
Statut
Membre
Dernière intervention
5 janvier 2013
-
Bonjour,
Je souhaite creer une fiche de calcul automatique pour la course d'orientation. J'ai creer mes barèmes... Mon problème : dans une cellule, je rentre le nombre de balise trouvés qui correspond à un nbre de points) - dans une autre le nbre de balise d'un Niveau (correspondant à un nbre de points). Je veux additionner les valeurs trouver dans les 2 cases précitées. Ci dessous la formule que j'utilise. Si je n'utilise que la formule des filles "f" ça marche, que celle des garçons "g"ça marche, mais l'addition des 2: PROBLEME (ça me marque #VALEUR! dans ma cellule.
=SI(G5="f";RECHERCHEV(D9;T6:U16;2;FAUX)+RECHERCHEV(D11;T19:U29;2;FAUX));SI(G5="g";RECHERCHEV(D9;L6:M16;2;FAUX)+RECHERCHEV(D11;L19:M29;2;FAUX))

Merci de votre aide
Erob



5 réponses

Messages postés
1491
Date d'inscription
vendredi 26 octobre 2012
Statut
Membre
Dernière intervention
28 janvier 2013
83
Bonsoir EROB,

Quel est le but recherché en faisant ces deux opérations car là la cellule est égal à ... SI; >>le point-virgule commence une autre opération .. conflit
Messages postés
8
Date d'inscription
jeudi 13 décembre 2012
Statut
Membre
Dernière intervention
5 janvier 2013

En fait, c'est d'avoir une note. Le total de mes 2 premières cellules D9 et D11 me donne une correspondance à un barême. Et c'est les 2 notes du barèmes qui me donneront la note finale. Il faut savoir que mon barème est différent s'il s'agit d'un garçon ou d'une fille (G5).
S'il y a conflit comment puis-je faire ?
Messages postés
1491
Date d'inscription
vendredi 26 octobre 2012
Statut
Membre
Dernière intervention
28 janvier 2013
83
Si c'est pour avoir une note finale des garçon + des filles, à la place du";" met "+"
et dis-moi si c'est que tu recherches
Messages postés
194
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
19 janvier 2013
22
Bonjour,
C'est normal que tu aies une erreur dans ce que tu appelles ton "addition", tu écris : =SI(G5="f";RECHERCHEV(D9;T6:U16;2;FAUX)+RECHERCHEV(D11;T19:U29;2;FAUX));SI(G5="g";RECHERCHEV(D9;L6:M16;2;FAUX)+RECHERCHEV(D11;L19:M29;2;FAUX))

La syntaxe aurait dû être SI( G5="f";RECHERCHEV(D9;T6:U16;2;FAUX)+RECHERCHEV(D11;T19:U29;2;FAUX) ; RECHERCHEV(D9;L6:M16;2;FAUX)+RECHERCHEV(D11;L19:M29;2;FAUX) )

En effet, à moins de faire concourir également les chiens, les chats et les poissons rouges, si ce n'est pas les filles, c'est forcément les garçons. La formule de SI donne " si A vrai alors B, sinon C " ; donc ton 2ème SI est en trop, en tous cas il n'a pas sa place à cet endroit. Après se pose la question, comme le demande Heliotte, de savoir ce que tu veux faire avec ta formule, car écrite comme cela tu auras toujours un résultat mais sans distinction entre filles et garçons. Mais cela toi seul le sais et peut-être n'auras-tu plus besoin de notre aide une fois les problèmes d'écriture résolus? Bonne journée et bon jeu.
Messages postés
8
Date d'inscription
jeudi 13 décembre 2012
Statut
Membre
Dernière intervention
5 janvier 2013

Bonjour Helliotte, bonjour Tessel75,
Super, mon pb est résolu. J'avais bien un SI en trop et des erreurs de syntax.
Merci à vous 2
A+
EROB