Formule avec plusieurs critères [Résolu/Fermé]

Signaler
-
 YOUKETTE -
Bonjour,

Je souhaiterais savoir faire une formule comprenant plusieurs critères, du syle :

Colonne A avec deux critères possibles :HD ou DD
Colonne B confirmation de ce critère : OK (si le critère en colonne A est bon) ou KO (si crière en en colonne A n'est pas bon)
Colonne C reprise du critère HD ou DD en fonction de OK ou KO

Résultat attendu : si HD et confirmé en colonne B avec un OK alors HD, mais si en colonne B je note KO alors DD, idem pour DD si confirmé avec OK alors DD, si infirmé avec KO alors HD.

La forme que j'arrive à faire ne me donne pas l'inverse !

Merci ++++ pour votre aide
Cordialement


1 réponse

Messages postés
25460
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 octobre 2020
5 565
Bonsoir
=SI(OU(ET(A1="DD";B1="KO");ET(A1="HD";B1="OK"));"HD";SI(OU(ET(A1="HD";B1="KO");(A1="DD";B1="OK"));"DD"))
crdlmnt

ne sommes nous pas seuls à comprendre ce que l'on explique?
TROP KOOL !!!! ça fonctionne super !
méga merci
Messages postés
25460
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 octobre 2020
5 565
curieux parce qu'à la relecture il y a une faute de frappe:
=SI(OU(ET(A1="DD";B1="KO");ET(A1="HD";B1="OK"));"HD";SI(OU(ET(A1="HD";B1="KO");ET(A1="DD";B1="OK"));"DD"))
MERCI +++ pour la réponse rectifiée !
Je l'avais pris en compte.

encore merci. cordialement