Debian VPN toujours mon IP de ma maison et pas de mon VPS?

[Résolu/Fermé]
Signaler
-
Messages postés
30111
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
-
Bonjour à toute la communauté !
Premièrement c'est mon 1er post sur CCM, merci d'être indulgent :)
Alors voilà je m'arrache les cheveux, j'essaie tant bien que mal avec mes maigres compétences à configurer mon serveur Linux (Debian 6) en VPN.
C'est dans le cadre d'etuliser mon propre VPN et masque mon adress ip domicil , je dois configurer un serveur distant en VPN, pour que client1 puissent se connecter à internet de manière sécurisée en passant par le VPS linux.
1- j'ai commandé pour 3,86 euro un VPS Linux sur first-root.com
Ok j'ai le VPS
2- je regarde moult Tuto, je m'embrouille, je perds du temps, j'apprends petit à petit le monde de Debian, bref je rame, mais à un moment je trouve une perle :
http://rrr.favrat.net/2009/09/17/installation-et-configuration-dopenvpn-sous-ubuntu/
Grace à ça je crée clefs certificats et compagnie pour le vpn
3- cela ne marche pas, je cherche donc un autre moyen :
http://doc.ubuntu-fr.org/openvpn
Alors là je crée client.ovpn et server ovpn en changeant par ci par là les info.
Je range les deux fichiers dans leur emplacement final respectif, je lance OpenVPN GUI depuis mon PC portable Windows 7
*******Pour une fois tout se met en VERT ! Oui il y a une connexion !*******
mais quand je vais sur http://mon-ip.com/ j'ai toujours mon IP de ma maison et là c'est pas terrible :( !
Je peux me connecter à mon VPS mais pas aller sur internet AVEC mon VPS :/
Quelqu'un aurait il une idée ?
Je peux vous transmettre server.ovpn, client.ovpn, et les détails de mon serveur.
J'espère recevoir une réponse.
Je vous remercie d'avance ! ;)

5 réponses

Messages postés
30111
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
7 173
Si le but est juste de masquer ton IP, pourquoi ne pas simplement utiliser tor ?

Avant d'aborder le problème vpn, si tu ne t'y connais pas trop en routage, je te conseille de lire le début de cet article, sinon ce qui suit risque d'être un peu abstrait :
http://www.mistra.fr/tutoriel-linux-configurer-le-reseau.html

La première chose à vérifier dans ton cas, c'est ta route par défaut.

/sbin/route -n


En effet, il y a de bonnes chance pour que ta route par défaut utilise toujours ton interface réseau connectée à ton routeur (typiquement eth0 si tu es connecté en ethernet) et via ton routeur et non par ta passerelle vpn (à laquelle tu accèdera par tun0 ou tap0).

Il est donc probable que la seule chose que tu aies à faire, c'est effacer la route par défaut (route del ....) et recréer une route par défaut qui utilise ta passerelle vpn. Ça doit ressembler à un truc de ce genre (à vérifier)

route del -net 0.0.0.0 netmask 0.0.0.0 dev eth0
route add default gw ip_du_serveur_vpn dev tap0


Bonne chance
je suis desolé,a nouveau, mamiemando,mais je vois "dev" dans tes commandes....il n'y a pas de risques a termes?....

@edit....tu va m'incendier c'est sûr!?! oh....^^
Messages postés
30111
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
7 173
T'incendier ? Pourquoi ?
Le mot clé dev est optionnel si tu regardes man ifconfig, tu peux l'omettre si tu veux.
Et sinon, les commandes routes ne sont pas très "gênantes". Au pire tu vas pêter ta table de routage et il suffira soit relancer le service réseau, soit (plus violent) de redémarrer. Typiquement sous debian :

service networking restart


... ou plus violemment

ifconfig eth0 down
ifconfig tap0 down
route -n
ifconfig eth0 up
ifconfig tap0 up
dhclient eth0
route -n
merci mamiemando
mais mon probleme je croix c'est le routage sous mon pc de la maison sous windows 7 pas sur mon vps (debian que j'ai instalé serveur vpn)
merci pour votre aide mamiemando
Messages postés
30111
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
7 173
Alors c'est une question pour le forum windows :-) Mais le problème est à mon avis le même il faut configurer windows pour que ta passerelle par défaut traverse ta passerelle vpn et non ton routeur. Je n'ai pas la moindre idée de comment ça se configure, je n'utilise pas windows.
resolu merci mamiemando pour votre aide

le probleme eté dans la ligne du server.conf sur ubuntu

push "redirect-gateway def1 bypass-dhcp"

je l'ai remplacer par c'elle si :

push "redirect-gateway def1"

tous marche bien
Messages postés
30111
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
7 173
Parfait bonne continuation !