Pré remplir une feuille excel [Résolu/Fermé]

Signaler
Messages postés
21
Date d'inscription
samedi 17 janvier 2009
Statut
Membre
Dernière intervention
18 mars 2015
-
Messages postés
21
Date d'inscription
samedi 17 janvier 2009
Statut
Membre
Dernière intervention
18 mars 2015
-
Bonjour,

J'ai préparé un tableau excel récapitulatif annuel: chaque cellule fait référence à des cellules de tous les mois de l'année qui se trouvent dans 12 autres fichiers, je souhaite que la valeur " " s'affiche lorsque le mois demandé n'existe pas et non pas #ref! car cela fausse la somme des 12 mois. Pour être plus claire, dans la colonne décembre les fichiers du mois n'ayant pas été créé, "#ref!" s'affiche et moi je souhaite qu'il affiche " " jusqu'à ce que le mois de décembre soit créé (Je ne peux pas créer tous les mois en avance) et là il indiquera ce qui ce trouve dans la cellule.
Je précise que j'utilise Excel 2010.

Je vous remercie de votre aide,
Cordialement
Sysoler


2 réponses

Messages postés
284
Date d'inscription
jeudi 12 janvier 2012
Statut
Membre
Dernière intervention
18 septembre 2019
8
Tu rajoutes une formule SI au tout début de ta formule

=SI(A1="";"";"DECEMBRE")

Le A1 et DECEMBRE sont juste des exemples, mais la formule dit que :

Si la cellule A1 est vide, alors ne rien inscrire dans la cellule, si il le mois est crée alors inscrire le mois.

le "" en test te laisse la cellule blanche elle n'est renvoyée par aucune valeur.
Messages postés
21
Date d'inscription
samedi 17 janvier 2009
Statut
Membre
Dernière intervention
18 mars 2015

Bonjour,

Cette formule ne fonctionne pas car a1 fait référence à un fichier qui n'est pas encore créé.
Je voudrais que en a1 qui fait référence à une cellule d'un fichier qui n'est pas créé, il ne mette rien et que dès que le fichier est créé, il mette la valeur de la cellule du fichier créé.
merci
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 330
Bonjour,
tu peux essayer de passer (je n'ai pas testé) par la fonction ESTERREUR(). exemple :

=SI(ESTERREUR(ta formule);"";ta formule)
Cela te permettra d'afficher "" quand le fichier n'est pas créé, et d'afficher ta valeur quand le fichier sera créé.
Messages postés
21
Date d'inscription
samedi 17 janvier 2009
Statut
Membre
Dernière intervention
18 mars 2015

Bonjour,
Avec un peu de retard dû à pas mal de problèmes....
Bref, merci de m'avoir aidé.
Et bonne année à tous
Bien cordialement