[mandriva 2007] installer aMule [Résolu/Fermé]

Signaler
Messages postés
54
Date d'inscription
jeudi 11 décembre 2003
Statut
Membre
Dernière intervention
15 avril 2012
-
Messages postés
59
Date d'inscription
jeudi 14 février 2008
Statut
Membre
Dernière intervention
2 janvier 2010
-
bonjour
J'essai d'installer aMule-2.1.3-wxGtk2.6.3_mdv.i586 sur mandriva 2007

voici ma méthode, méthode que j'utilisai sur mandrake 9.1 je fais un lien de la librairie en mettant le nom demandé par emule:

[root@localhost Desktop]# rpm -ivh aMule-2.1.3-wxGtk2.6.3_mdv.i586.rpm
Préparation... ########################################### [100%]
1:aMule ########################################### [100%]

[root@localhost Desktop]# amule
amule: error while loading shared libraries: libbfd-2.16.91.0.2.so: cannot open shared object file: No such file or directory

[root@localhost Desktop]# ln /usr/lib/libbfd-2.16.91.0.7.so /usr/lib/libbfd-2.16.91.0.2.so

[root@localhost Desktop]# amule
amule: error while loading shared libraries: libwx_gtk2u_adv-2.6.so.0: cannot open shared object file: No such file or directory

[root@localhost Desktop]# ln /usr/lib/libwx_gtk2_adv-2.6.so.0 /usr/lib/libwx_gtk2u_adv-2.6.so.0

[root@localhost Desktop]# amule
amule: error while loading shared libraries: libwx_gtk2u_core-2.6.so.0: cannot open shared object file: No such file or directory

[root@localhost Desktop]# ln /usr/lib/libwx_gtk2_core-2.6.so.0 /usr/lib/libwx_gtk2u_core-2.6.so.0

[root@localhost Desktop]# amule
amule: error while loading shared libraries: libwx_baseu_net-2.6.so.0: cannot open shared object file: No such file or directory

[root@localhost Desktop]# ln /usr/lib/libwx_base_net-2.6.so.0 /usr/lib/libwx_baseu_net-2.6.so.0

[root@localhost Desktop]# amule
amule: error while loading shared libraries: libwx_baseu-2.6.so.0: cannot open shared object file: No such file or directory

[root@localhost Desktop]# ln /usr/lib/libwx_base-2.6.so.0 /usr/lib/libwx_baseu-2.6.so.0

[root@localhost Desktop]# amule
amule: /usr/lib/libwx_gtk2u_adv-2.6.so.0: version `WXU_2.6' not found (required by amule)
amule: /usr/lib/libwx_baseu-2.6.so.0: version `WXU_2.6' not found (required by amule)
amule: /usr/lib/libwx_baseu_net-2.6.so.0: version `WXU_2.6' not found (required by amule)
amule: /usr/lib/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6.2' not found (required by amule)
amule: /usr/lib/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6.3' not found (required by amule)
amule: /usr/lib/libwx_gtk2u_core-2.6.so.0: version `WXU_2.6' not found (required by amule)

Si quelqu'un peu me dire comment installer aMule sur mandriva 2007 je serai ravi

Merci d'avance


3 réponses

Messages postés
54
Date d'inscription
jeudi 11 décembre 2003
Statut
Membre
Dernière intervention
15 avril 2012
6
j'ai trouvé :

package a installer --> libwxgtku2.6-2.6.3-8mdv2007.1.i586.rpm
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
54
Date d'inscription
jeudi 11 décembre 2003
Statut
Membre
Dernière intervention
15 avril 2012
6
bon j'ai trouvé le package wxGTK-2.6.3-1.fc1.rf.i386.rpm qui contient libwx_gtk2u_adv-2.6.so.0

Mais lorsque je lance aMule :

[root@localhost Desktop]# amule
amule: Symbol `_ZTI7wxSizer' has different size in shared object, consider re-linking
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.6 (no debug,Unicode,compiler with C++ ABI 102,wx containers,compatible with 2.4),
and your program used 2.6 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4).
Abandon

Voila
Messages postés
59
Date d'inscription
jeudi 14 février 2008
Statut
Membre
Dernière intervention
2 janvier 2010
7
comment installer ce package ?