Gérer les références à plusieurs feuilles de calcul sur Excel [Résolu/Fermé]

Signaler
-
 Maindi -
Bonjour,
Sur Microsoft Excel 2010, à partir de plusieurs feuilles de calculs (le même tableau avec les mêmes intitulés, mais des données différentes), je voudrais créer une feuille de synthèse qui permettrait de comparer rapidement les données essentielles. Chaque ligne correspondrait à une fiche, et on pourrait en un coup d'oeil comparer les données, puis éventuellement en calculer les moyennes etc.
Je recrée un tableau dans la feuille de synthèse, et crée les liens avec les cellules de ma première fiche (nommée F1). Avec des formules telles que "='F1'!C2" ou "=SOMME('F1'!C18:C19)".
Chaque fiche étant construite exactement de la même manière, je voudrais maintenant trouver un moyen automatique de remplacer F1 par F2 dans la seconde ligne, par F3 dans la suivante et ainsi de suite.
J'ai essayé de bloquer les L et C des cellules avec "$" avant de cliquer en bas à droite de la cellule et de tirer les formules, mais ça n'a pas marché.

J'espère que quelqu'un pourra m'aider!
Merci!


2 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 235
bonjour

Il te faut utiliser INDIRECT, par exemple en ligne 2 de ta récap :

=INDIRECT("'F"&LIGNE()-1&"'!C2")

et tu peux tirer ta formule en descendant.
Merci beaucoup gbinforme! ça marche!

Pour les débutants comme moi qui auront du mal à mettre en place la fonction INDIRECT, je conseille ce lien:
http://www.excel-exercice.com/fonction-indirect/

Bon courage à tous sur excel!
Messages postés
5525
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
30 octobre 2020
516
Bonjour

construire cette formule

="='F"&D1&"'!"&"B4"
ou D1 égale le numéro de la feuille 1 et ainsi de suite incrémenter D2 = 2, D3 = 3 ...
B4 la cellule à récupérer sur la feuille F1
tirer la formule sur la hauteur voulu et copier/coller valeur sur place
et fonction F2 et entrer sur chaque formule
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 235
Bonjour,

Effectivement pourquoi ne pas compliquer un peu la situation lorsque l'on peut faire simple :)