Fonction excel : Affectation automatique de référence ?

[Résolu/Fermé]
Signaler
Messages postés
4
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
29 octobre 2012
-
Messages postés
4
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
29 octobre 2012
-
Bonjour,

Voici mon problème : J'ai 2 fichiers Excel
Fichier 1 : contenant les références de mes prospects (Nom + N° client), environ 3000.
Fichier 2 : le Nom d'une partie de mes prospects du fichier 1, environ 200, sans le N° client.

Quid : comment affecter aux prospects du fichier 2 leur N° client qui se trouve dans le fichier 1 ?

D'avance merci pour votre aide.



4 réponses

Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
alors effectivement si le N° est avant le nom,RECHERCHEV ne fonctionne pas,
vous pouvez appliquer sur le même principe de construction:


=SI(A1="";"";SI(NB.SI(colonne des noms;A1)=0;"Non référencé";(INDEX(Colonne des N°;EQUIV(A1;colonne des Noms;0))))

bien entendu il faut que les noms soient inscrits rigoureusement de la même manière dans les deux listes.
crdlmnt
ne sommes nous pas seuls à comprendre ce que l'on explique?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
177
Bonjour,
Un RECHERCHEV devrait faire l'affaire, pourrais-tu poster un extrait de ton fichier anonymisé ? Via cjoint par exemple.
Messages postés
4
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
29 octobre 2012

Voici à quoi correspond mon fichier 1

N° Client Nom
5170132 FIX BERTHE
5430002 FAUVETTE SONIA
6040009 PROCIDA Patrick
6640005 ANESSAUT Muguette
6870001 MATTETI Massimo
6990002 CONTAULT JACQUELINE
7050009 CHUWES Shlomo
7140004 ELIFLOR
7210001 NADJI Kada
7480004 ASSOCIATION JEUNES EMPLOI

Voici à quoi correspond mon fichier 2

Nom
PROCIDA Patrick
ANESSAUT Muguette
MATTETI Massimo
CONTAULT JACQUELINE
CHUWES Shlomo
ASSOCIATION JEUNES EMPLOI

Comment affecter les N° clients automatiquement dans le fichier 2
Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
177
Re,
Comme le dit Vaucluse : il faut d'abord séparer le n° client du nom dans le fichier 1 (séparation en deux colonne), puis appliquer la formule qu'il a écrite.
Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Bonjour
exemple à adapter:
Fichier1 vos données avec en colonne A nom et en colonne B N°
Fichier2 votre liste à documenter avec les noms en colonne A

La meilleures façon de préciser l'adresse des champs de références est d'ouvrir les deux fichier et de procéder aux sélections directement dans les tableaux:

dans le fichier 2 en A1, une formule qui de surcroît éliminera les affichages parasites en cas d'erreur:

=SI(A1="";"";(RECHERCHEV(A1; champ sélectionné;2;0))

champ sélectionné: sélectionnez directement le champ dans le fichier concerné pour que l'adresse s'inscrive automatiquement
si vous risquez d'avoir des noms de client en fichier 2 qui n'existe pas dans le fichier 1, vous pouvez écrire:

==SI(A1="";"";SI(NB.SI(colonne A du champ de base;A1)=0;"Non référencé";(RECHERCHEV(A1; champ sélectionné;2;0)))

crdlmnt

Messages postés
4
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
29 octobre 2012

Merci ça marche impeccablement ! Cordialement.