Probleme de formule calc

Résolu/Fermé
tooney05 Messages postés 38 Date d'inscription lundi 15 octobre 2012 Statut Membre Dernière intervention 29 décembre 2016 - 15 oct. 2012 à 21:23
tooney05 Messages postés 38 Date d'inscription lundi 15 octobre 2012 Statut Membre Dernière intervention 29 décembre 2016 - 22 oct. 2012 à 19:43
Bonjour,

J'essai d'etablir un planning pour la garde de notre enfant. fichier joint https://www.cjoint.com/?3Jpvq5qhWy9

lorsque je rentre une lette (qui correspond a un horaire) dans la colone B, je voudrais que les colonne C D E F G, se remplissent seul en allant chercher les valeurs dans la base de donnée (feuille base).

Or dans la pratique, ma formule fonctionne mais des erreurs se glissent (cellules en rouge).

je ne comprends pas pourquoi!!!

Merci de me donner la solution si vous la connaissez.

cdlt


3 réponses

Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 926
Modifié par Mytå le 15/10/2012 à 22:50
Salut le forum

Formule en C8 à recopier vers le bas
=SI(B8="";"";RECHERCHEV(B8;Base!$A$3:$F$37;2;0))

Tu remplaces le 2 par 3 ,4 ... pour les autres colonnes

Mytå
0
tooney05 Messages postés 38 Date d'inscription lundi 15 octobre 2012 Statut Membre Dernière intervention 29 décembre 2016 12
18 oct. 2012 à 20:19
Merci cela fonctionne. pourquoi des erreurs dans ma formule?

cdlt
0
Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 926
22 oct. 2012 à 03:22
Re le forum

Ton problème avec RECHERCHE
=RECHERCHE(B8;Base!$A$3:$A$37;Base!$B$3:$B$37)
Les valeurs de l'argument vecteur_recherche doivent être placées en ordre croissant : ..., -2, -1, 0, 1, 2, ..., A-Z, FAUX, VRAI. Sinon, la fonction RECHERCHE peut renvoyer une valeur incorrecte. Les majuscules les et minuscules sont traitées indifféremment.

Mytå
0
tooney05 Messages postés 38 Date d'inscription lundi 15 octobre 2012 Statut Membre Dernière intervention 29 décembre 2016 12
22 oct. 2012 à 19:43
Merci pour l'info!

a+!
0
Raymond PENTIER Messages postés 56988 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 30 janvier 2023 17 172
22 oct. 2012 à 02:48
Ton lien n'est pas accessible.
Renvoie ton fichier.
0
tooney05 Messages postés 38 Date d'inscription lundi 15 octobre 2012 Statut Membre Dernière intervention 29 décembre 2016 12
22 oct. 2012 à 19:43
Bonsoir

Mon probleme est résolu.

merci
0