[excel] recherche et comptage de doublon [Résolu/Fermé]

Signaler
Messages postés
237
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
28 mai 2016
-
Messages postés
237
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
28 mai 2016
-
Bonjour,
Apres avoir pas mal cherché sur le net, je reviens une fois de plus vers vous.
Je suis en train de construire un userform dans le but de rentrer les horaires journalier de travail et de compter les jours de repos de chaque jour/an

dans la colonne C j'ai une liste de jour (du lundi au dimanche, répété plusieurs fois)
dans la colonne E j'ai une liste ou est inscrit des plages horaires ou jours de repos

mon but est de compter combien j'ai eu de repos un lundi, un mardi etc... jusqu'au dimanche et ce dans l'année

Vu que je pense que je n'ai pas très bien expliquer je link mon classeur

https://www.cjoint.com/?BItsxtZpvU4

je ne sais pas si on peut calculer directement en code vba ou s il faut le calculer depuis une cellule de la feuille"Data"

J'espère que vous aurez compris ma question
De plus je ne suis pas très doué en vba, je me borne pour l'instant à bricoler des bouts de codes glaner sur le net.

merci pour toute aide

2 réponses

Messages postés
25755
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 janvier 2021
5 716
Bonsoir
essayez avec la formule, si j'ai bien compris:
=SOMMEPROD(($C$1:$C$366="Lundi")*($E$1:$E$366="Repos"))
et si vous voulez compter par mois:
=SOMME.PROD(($C$1:$C$366="Lundi")*($A$1:$A$366="Décembre")*($E$1:$E$366="Repos$))
vous pouvez bien sur remplacer "Lundi" et "Décembre" par des adresses de cellules (sans guillemets) dans les quelles vous placerez les valeurs cherchées

autre possibilité sur Excel à partir de 2007

=NB.SI.ENS($C$A:$C$366;"Lundi";$A$1:$A366;"Décembre";$E$1:$E$366;Repos")

crdlmnt
Messages postés
237
Date d'inscription
samedi 19 juillet 2008
Statut
Membre
Dernière intervention
28 mai 2016
4
la première réponse est exactement ce que je cherchais.

Merci beaucoup Vaucluse :)