Excel : somme en fonction de 2 critères [Résolu/Fermé]

Signaler
Messages postés
22
Date d'inscription
mercredi 19 septembre 2012
Statut
Membre
Dernière intervention
26 juillet 2014
-
Messages postés
22
Date d'inscription
mercredi 19 septembre 2012
Statut
Membre
Dernière intervention
26 juillet 2014
-
Bonjour,

Dans Excel, je voudrais regrouper sur une même ligne les quantités de plusieurs lignes en fonction d'un numéro de commande (sans faire de tableau croisé dynamique). Sur une même commande, je peux avoir de 1 à 4 lignes. J'ai déjà déterminé le nombre de commande avec la formule suivante (pour la 1ère ligne, colonne Nb cde):
=SI(A2=A1;0;1)

N° commande Date Produit Qtés Nb cde Total Quantité
12975 30/01/2012 A 306 1
12975 30/01/2012 B 288 0
12984 30/03/2012 A 155 1
12984 30/03/2012 B 24 0
12984 30/03/2012 D 173 0
12984 30/03/2012 C 107 0
13014 30/04/2012 C 308 1

Donc, j'aimerai avoir les quantités totales des commandes dans la colonne "totale quantité" lorsque le nombre "1" apparait dans la commande "Nb de cde"

Merci par avance de votre aide

2 réponses

Messages postés
25627
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 novembre 2020
5 628
Bonjour
si on s'en tient à votre demande, le 1 n'est pas utile!De plus on voit mal comment cette formule peur résoudre votre question puisque le 1 va s'afficher à chaque N° de commande quel qu'il soit à partir du moment ou le n° précédent est identique!!

Je vous propose directement une de ces formules dans la colonne total quantité, en supposant que votre liste va de ligne 1 à ligne 1000, à adapter:

1°) pour avoir le total quantité en face de chacune des références:
en ligne 2
=SOMME.SI($A$2:$A$1000;A2;$D$1:$D$1000)
attention aux signes

2°) pour avoir le total quantité en ligne uniquement avec le dernier code commande , les lignes précédentes avec le même code restant vides:
en ligne 2 toujours
=SI(NB.SI(A2:$A$1000;A2)=1;SOMME.SI($A$2:$A$1000;A2;$D$2:$D$1000);""))

Faites très attention à la position des signes, surtout les signes $

Revenez si ça ne convient pas,

si par exemple vous voulez un tableau qui récapitule les N° de commande et les quantités :
Dans la colonne (colonne E)ou vous avez placé les 1 et b0, remlacez par cette formule:
=SI(NB.SI(A2:$A$1000;A2)=1;MAX($E$1:E1)+1;0)
toujours en commençant sur ligne 2. Et attention aux signes$!!!!!

dans le tableau récapitulatif, par exemple commençant en K2
la formule en K2:
=SI(LIGNE()-1>MAX(E:E);"";INDEX(A:A;EQUIV(LIGNE()-1;E:E;0))
vous renverra le N° de commande
en L2
=SOMME.SI(A:A;K2;D:D)
vous renverra le total des quantités

Crdlmnt



ne sommes nous pas seuls à comprendre ce que l'on explique?
Messages postés
22
Date d'inscription
mercredi 19 septembre 2012
Statut
Membre
Dernière intervention
26 juillet 2014

Merci beaucoup c'est ce qu'il me fallait !

Juste une petite correction sur le 2°) car il y avait une parenthèse en trop. La formule est :
=SI(NB.SI(A2:$A$1000;A2)=1;SOMME.SI($A$2:$A$1000;A2;$D$2:$D$1000);"")