Recherche formule Excel [Résolu/Fermé]

Signaler
-
Messages postés
25418
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2020
-
Bonjour,

J'ai vraiment besoin d'aide concernant un tableau de tarifs sur Excel.
Je dois mettre à jour ces tarifs et il y a deux types de groupes : le groupe 1 qui bénéficie d'une remise de 36% et le groupe 2 d'une remise de 31%.
Mais le tableau n'est pas classé en fonction des groupes, tout est mélangé !
J'ai ma colonne D qui représente les groupes 1 et 2 et la colonne E qui indique les prix que je dois changer.
Voici la formule qui m'a semblée la plus adaptée :
=si(d7=1;e7*36%;e7*31%)
Mais Excel ne prend en compte que les 31% ! Je ne comprends plus, aidez-moi !
Merci d'avance !

6 réponses

Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
157
Bonjour,
La formule semble correcte...
Mais si la fonction ne revoie que le calcul si la condition est fausse, ça veut dire que la condition est mal écrite (s'il y a des groupe 1 en colonne D).
Est-ce que la colonne D ne contient que 1 ou 2 ? Ou Groupe1 et Groupe2 ?

Il faut que la condition corresponde exactement pour que la formule renvoie la partie "condition_si_vrai".
La colonne D ne contient que les valeurs "01" et "02". Mais la formule ne tient pas cela en compte, il ne prend que la partie "e7*31%".
Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
157
Est-ce que les "01" et "02" sont du texte?
Essaye en écrivant :
=SI(D7="01";E7*36%;E7*31%) 
J'ai aussi mis le "01" mais Excel l'annule directement et le remplace par "1". J'ai vérifié, c'est bien un nombre.
Messages postés
17285
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 octobre 2020
4 301
Salut,

ta formule est correcte
=SI(D2=1;D2*36%;E2*31%)
ou ce qui évitera les zéro lorsque les cellules ne sont pas renseignées
=SI(D2=1;E2*36%;SI(D2=2;D2*31%;""))

regarde du coté des formats de tes cellules
si tu ne trouve pas, fait nous une copie de ton fichier en supprimant les données confidentielles et colle le fichier dans un post avec ce lien

https://www.cjoint.com/
J'ai déjà essayé cette formule, mais la réponse est zéro ! Je n'ai pas mis les guillemets à la fin. Je vous envoie une copie du fichier !
C'est gentil à vous en tout cas, merci !!
Messages postés
25418
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2020
5 546
Bonjour

A vérifier on ne sait jamais:

votre 1 dans la colonne D est il bien numérique et les cellules sont elles bien en format standard (le chiffre 1 doit s'afficher à droite de la cellule en alignement "standard")
Le problème peut se poser si votre 1 vient d'un menu déroulant de formant texte ou d'une copie d'un autre fichier, ou encore si la colonne D est en format "Texte"

si votre 1 n'est pas num:, soit vous transformez votre code en num, soit vous écrivez la formule en plaçant le 1 entre guillemets
(transformer rapidement le code en num à toutes fins utiles:
sélectionner une cellule vide hors champ, la copier, sélectionner la champ à modifier et clic droit collage spécial / cocher addition

crdlmnt


Voici le lien de mon fichier.


http://cjoint.com/?3InkKv3s2Gi
Messages postés
25418
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2020
5 546
Bonjour
hé bé alors?
.... le code dans votre fichier en D n'st pas 1 (num ou texte) mais 01 ?????
dons forcément en texte de surcroit

alors au lieu de 1 dans votre formule, placez donc:
"01"



crdlmnt

ne sommes nous pas seuls à comprendre ce que l'on explique?
Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
157
Avec pleeeeein d'espaces avant... la formule exacte est donc :
=SI(D7="        01";E7*36%;E7*31%)
Messages postés
25418
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2020
5 546
... et en plus avec vérification, le 01 se compose d'une série de blanc avant le texte 01!!!!
alors pour faciliter les choses, traiter d'abord la colonne D pour conserver le 1 seul
sélectionnez colonne D complète et appliquer l'opération avec la ce collage spécial expliquée au message précédent et utilisez le 1 sans guillemets
si par contre vous voulez conserver le code tel quel, placer entre les guillemets de votre formule
" 01" avec huit blancs avant le 01 et ça va marcher.

Pour info:
un nombre qui commence par 0 en Excel est une valeur texte pour Excel, sauf dans les formats spéciaux N° de tèl.


crdlmnt
J'ai remplacé le 01 par 1 et le 02 par 2 dans la colonne D et ça fonctionne !!!! Je vous remercie tous !!