Excel: coordonnées par une valeur

Résolu/Fermé
Signaler
-
Messages postés
24288
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 janvier 2022
-
Bonjour,

le titre est un peu compliqué, mais la réponse est surement toute bête seulement je ne suis en train de m'arracher les cheveux à pas trouver!

Voilà mon problème, j'ai la formule suivante, peu importe les chiffre et le type de fonction:
=RECHERCHEV($D$4;Feuille1.$A$189:$I$7302;6;0)

Cette fonction fonctionne très bien tel quel, mon problème est que le chiffre 189 (ligne) varie et est automatisé, sa valeur est récupérée dans une case du tableau.
Comment faire pour intégrer cette valeur issue d'une case du tableau dans ma fonction??

Merci d'avance pour vos réponses!

4 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 304
Bonjour,

essaie avec :

=RECHERCHEV($D$4;Feuille1.$A$ & INDIRECT(la_cellule_contenant_le_num_de_ligne) & $I$7302;6;0)

Cordialement.
0
Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
50
bonjour,

pour simplifier le travail dans la formule recherchev il faut renommer le tableau qu'on utilise
tu trouveras la technique dans ce fichier (prends uniquement la partie qui te concerne)

https://www.cjoint.com/?BHksIKHGej6

de cette manière on appelle un tableau dans la fonction et non des cellules sélectionnées qui varient...
0
Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
50
il faut que tu suives les points 1 et 3, le 2 tu dois connaitre normalement
0
Merci pour vos réponses rapides!

chossette9, ça ne fonctionne pas!

tichacha14, merci pour le conseil que je suivrai, mais ça ne résoudra pas mon problème je pense!

Pour simplifier, au lieu d'écrire =a189
je cherche à écrire =a(coordonnées_de_la cellule_qui_contient_le_numero_de_ligne) (qui est égal à 189 dans ce cas précis)
et que donc excel comprenne que je cherche la valeur de la cellule a189!
0
Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
50
ah ok mais quel est l'intérêt de la recherchev dans ce cas ?
0
Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
50
dans le tableau de la fonction la valeur cherchée doit être inscrite dans la première ligne, ensuite on sélectionne le tableau où doit être cherchée la valeur normalement
0
la recherchev c'est dans ce cas précis mais elle ne me pose pas de problème, le seul problème que j'ai c'est que j'aimerai récupérer la valeur de la cellule a189 en disant à excel de chercher ce 189 dans une cellule, et pas en le tapant!
0
Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
50
dans ce cas il faut saisir $A$189 dans la première ligne de la fonction...
0
Messages postés
282
Date d'inscription
mercredi 25 juillet 2012
Statut
Membre
Dernière intervention
25 avril 2016
50
j'essaye de répondre mais je ne suis pas sure de bien saisir ta demande
je m'excuse si je réponds à côté de la plaque
0
Messages postés
24288
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 janvier 2022
7 033
Bonsoir,

=RECHERCHEV($D$4;DECALER(Feuil1!A1;C2-1;100;9);6;0)
en C2: n° ligne 1ère cellule de la plage de recherche.
100 : hauteur de la plage de recherche.
9 : largeur de la plage de recherche.
eric
Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
0
J'ai essayé, ça ne fonctionne pas non plus!

Mais c'est bon, j'ai réglé mon problème en prenant d'autres voies, je serai bien incapable de l'expliquer mais c'est fait ;)!

Merci beaucoup en tout cas!
0
Messages postés
24288
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 janvier 2022
7 033
ça ne fonctionne pas non plus
Je teste toujours avant de proposer.
0