Recherche valeurs et association dans EXCEL

Fermé
Signaler
Messages postés
6
Date d'inscription
lundi 6 août 2012
Statut
Membre
Dernière intervention
6 août 2012
-
Messages postés
10197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 janvier 2022
-
Bonjour,

Je me permets de vous envoyer cette petite question. Je tourne en rond et ne parviens pas à résoudre mon problème. Le voici :

- J'ai 1 liste déjà existante que j'enrichie régulièrement que l'on appelera "Liste base"
- J'ai 1 liste nouvelle que l'on appelera "Liste nouvelle"

J'aimerais croiser la "Liste nouvelle" avec la "Liste base".

Mon objectif est de savoir si une valeur de la "Liste nouvelle" apparait dans la "Liste base" et si OUI, marquer 1 dans une autre cellule.

Attention, ces listes (donc colonne) ne sont pas côte à côte, ne sont pas composées du même nombre de ligne......

Merci beaucoup pour votre aide, j'ai absolument besoin de cette formule !

Merci beaucoup
Alex


10 réponses

Messages postés
1235
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
179
Bonjour,
Comme ceci?
Attention, la formule en colonne C est une formule matricielle, à valider avec CTRL+SHIFT+ENTREE
0
Messages postés
10197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 janvier 2022
2 275
bonjour et re salut Morgothal

ou comme ceci ... si j'ai bien compris la question

https://www.cjoint.com/?0HgqhI5zYdG

bonne suite
0
Messages postés
6
Date d'inscription
lundi 6 août 2012
Statut
Membre
Dernière intervention
6 août 2012

Je vais regarder ce que vous m'avez envoyé mais d'ores et déjà je vous remercie pour votre aide trés précieuse.

Je reviens vers vous si besoin.

Merci
Alexandre
0
Messages postés
6
Date d'inscription
lundi 6 août 2012
Statut
Membre
Dernière intervention
6 août 2012

re,

Bon ce n'est pas tout à fait cela... ;-)

En fait j'essaie de croiser des valeurs dans 2 colonnes mais ces 2 listes ne sont pas côte à côte, les mêmes valeurs ne seront pas sur la même ligne et le champ à inscrire (si VRAI) sera à placer sur une autre colonne et autre ligne.

Plus concrètement, voici le fichier en PJ :
https://www.cjoint.com/?BHgrjTYjiiP

J'ai une base liste d'adresses email et j'aimerais savoir si une adresse email de la nouvelle liste appartient à cette base liste. Si OUI alors placer "1" ou autre valeur dans une nouvelle cellule (voir colonne CONCLUSION).

MERCI
Alex
0
Messages postés
10197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 janvier 2022
2 275
je t'avais fait la manip. dans la feuille Nouvelle, mais c'est la même chose
https://www.cjoint.com/?0HgrvbjLRzn
0
Messages postés
6
Date d'inscription
lundi 6 août 2012
Statut
Membre
Dernière intervention
6 août 2012

Super MERCI !

Par contre, dans ton exemple, comment fais tu pour geler la colonne de la "nouvelle liste" (toujours A2:A9) ?

Merci
Alex
0
Messages postés
6
Date d'inscription
lundi 6 août 2012
Statut
Membre
Dernière intervention
6 août 2012

la formule de base :

=NB.SI('Nouvelle liste'!A2:A9;'Base liste'!A2)
0
Messages postés
10197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 janvier 2022
2 275
=NB.SI('Nouvelle liste'!$A$2:$A$9;'Base liste'!A2)

le lieux serait de nommer cette plage de façon dynamique (formule verte), comme ça tout ajout dans la nouvelle liste serait pris en compte (voir feuille nouvelle)

https://www.cjoint.com/?0HgrY0kjKUe
0
Messages postés
6
Date d'inscription
lundi 6 août 2012
Statut
Membre
Dernière intervention
6 août 2012

Oui effectivement c'est trés intéressant et ça peut m'être utile !

Par contre dernière chose, comment définis tu la valeur à insérer ? Comment as tu défini "1" comme valeur à insérer si OUI ? Comment pourvons-nous insérer par exemple "4" ?

Après je te laisse tranquille ;-)

Merci
0
Messages postés
10197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 janvier 2022
2 275
tu avais demandé des 1 ou des 0
la fonction NB.SI renvoie le nombre d'occurrences correspondant au critère choisi ici = A2
si tu veux autre chose
=SI(NB.SI( ...... )>0;"titi";toto") 

bonne suite
0