Insérer WMV: contrôle de lecture dans Firefox

Fermé
[HTML] Insérer WMV => Contrôle de lecture dans Firefox - 7 janv. 2007 à 22:23
 bontbont - 7 avril 2011 à 13:34
Bonjour,
J'ai inséré une séquence vidéo encodée en WMV dans ma page WEB.
Les contrôles de lecture (WMP11) apparaissent bien dans IE7 mais pas dans Firefox 2.0.0.1!
Les contrôles apparaissent très succintement dans firefox lors du chargement de la page, mais disparaissent aussitôt la page entièrement chargée!
Voilà ma page:
https://lxweb1.edpnet.net/pma/


<object type="video/x-ms-wmv" data="../nature/Caroux.wmv" width="640" height="480" id="WMPlayer">
<param name="src" value="../nature/Caroux.wmv">
<param name="autostart" value="0">
<PARAM NAME="repeat" VALUE="-1">
<PARAM name="showcontrols" VALUE="true">
alt : <a href="../nature/Caroux.wmv">Caroux.wmv</a>
</object>

ou sans définir le type
<object data="../nature/Caroux.wmv" width="640" height="480" id="WMPlayer">
<param name="src" value="../nature/Caroux.wmv">
<param name="autostart" value="0">
<PARAM NAME="repeat" VALUE="-1">
<PARAM name="showcontrols" VALUE="true">
alt : <a href="../nature/Caroux.wmv">Caroux.wmv</a>
</object>


Sur cette page:
http://joliclic.free.fr/html/object-tag/object-video.html le test marche bien et les contrôles de lecture apparaisent bien.
Je ne vois pas de différences fondamentales entre le code de ma page et celui de la page cité ci dessus!

La présence ou absente de la balise
<PARAM name="showcontrols" VALUE="true">
ne change rien à l'histoire!

La première fois que IE répond à mes attentes et pas firefox! LOL! :)

Peut être que chez vous les contrôles apparissent?

Merci pour vos lumières!

8 réponses

Jpat Messages postés 433 Date d'inscription lundi 29 janvier 2007 Statut Membre Dernière intervention 23 avril 2022 156
9 août 2008 à 08:56
J'avais déjà essayé ce code mais il ne marche pas non plus si l'on veut que la vidéo ne démarre pas automatiquement.

Dans ton exemple tu as bien mentionné <param name="AutoStart" value="false"> mais regarde : il n'en tient pas compte puisque la vidéo démarre seule.

Or sur ma page définitive c'est rédhibitoire : j'ai plusieurs vidéos sur la même page et je ne veux pas qu'elles démarrent toutes en même temps.
3
marcetch64 Messages postés 11 Date d'inscription jeudi 17 janvier 2008 Statut Membre Dernière intervention 18 janvier 2008 16
17 janv. 2008 à 08:48
Bonjour

Ave ce code, ça marche sur Firefox et IE :

<div>
<embed type="application/x-mplayer2" src="URL de la video.wmv" width="384" height="358"
autostart="1"
showcontrols="1"
showtracker ="1"
showstatusbar="1"></embed>
</div>

Les paramètres src=" ", width et height sont à ajuster selon la vidéo
On peut ainsi avoir toutes les infos sur la vidéo, progression, titre, durée etc....

Marc
2
Merci merci merci et merci, pourquoi faire compliqué quand c'est si simple... je cherchais moi aussi et depuis 2 jours et s'est toi qui m'a donné la solution !
0
dugenou Messages postés 6083 Date d'inscription mercredi 19 janvier 2005 Statut Contributeur Dernière intervention 30 juillet 2021 1 454
9 août 2008 à 08:26
Bonjour,

Voici un script qui fonctionne sous IE comme sous FF :

<object id="video1" width=480 height=360 classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
codebase="http://activex.microsoft.com/activex/controls/
mplayer/en/nsmp2inf.cab#Version=6,4,5,715"
standby="Chargement..."
type="application/x-oleobject">
<param name="FileName" value="fichier.wmv">
<param name="AutoStart" value="false">
<embed type="application/x-mplayer2"
pluginspage = "https://support.microsoft.com/en-us/windows/get-windows-media-player-81718e0d-cfce-25b1-aee3-94596b658287"
src="fichier.wmv"
name="video1" width=480 height=360 AutoStart=false>
</embed>
</object>


Voir un exemple sur cette page :

http://phortail.free.fr
1
dugenou Messages postés 6083 Date d'inscription mercredi 19 janvier 2005 Statut Contributeur Dernière intervention 30 juillet 2021 1 454
9 août 2008 à 09:11
Si tu veux que la vidéo ne démarre pas automatiquement :

<object id="video1" width=480 height=360 classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
codebase="http://activex.microsoft.com/activex/controls/
mplayer/en/nsmp2inf.cab#Version=6,4,5,715"
standby="Chargement..."
type="application/x-oleobject">
<param name="FileName" value="fichier.wmv">
<param name="AutoStart" value="0">
<embed type="application/x-mplayer2"
pluginspage = "https://support.microsoft.com/en-us/windows/get-windows-media-player-81718e0d-cfce-25b1-aee3-94596b658287"
src="fichier.wmv"
name="video1" width=480 height=360 AutoStart=0>
</embed>
</object>
1

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Salut, j'arrive a afficher mon controle dans un navigateur firefox.

cependant il a falut que je m'assure que certaines chose etait en place.

dabord tes balises "param" il faut que tu t'assure de les fermer avec />.

puis quand tu ecris tes "param" ou toute autre balise, ne met aucune majuscules.

<object type="video/x-ms-wmv" data=" mavideo.wmv" width="640" height="480" id="WMPlayer">
<param name="src" value="mavideo.wmv"/>
<param name="autostart" value="1"/> 
<param name="repeat" value="-1"/>
<param name="showcontrols" value="true"/>
alt : <a href="mavideo.urldemavideo.com"><"Si la vidéo ne s'affiche pas"</a>
</object>


bon courage
Juls
0
Jpat Messages postés 433 Date d'inscription lundi 29 janvier 2007 Statut Membre Dernière intervention 23 avril 2022 156
9 août 2008 à 08:11
Bonjour, j'ai le même problème et hélas la solution indiquée ne marchent pas !

Voir ma page test avec les 2 méthodes citées dans ce fil qui donnent toutes les 2 un écran noir avec Firefox alors qu'elles fonctionnent très bien avec IE :

http://propentes.free.fr/test01.html

Je vais finir par croire qu'il est impossible de lire une vidéo WMV avec Firefox, pourtan t dans l'exmple cité en premier ça marche...
0
Jpat Messages postés 433 Date d'inscription lundi 29 janvier 2007 Statut Membre Dernière intervention 23 avril 2022 156
9 août 2008 à 09:36
Merci de t'occuper de moi.
On avance...
Ton code fonctionne, mais lorsque je veux redimensionner la vidéo (plus petit), ça ne marche plus.

Voici une démo avec 3 dimensions différentes :

http://propentes.free.fr/test01.html

Où l'on voit qu'en fait mon problème vient d'une histoire de redimensionnement de la vidéo. Le code marche, mais le panneau de contrôle disparaît au fur et à mesure qu'on rétrécit la vidéo !

Ca paraît tout bête, je suis proche du but mais je ne vois pas... (Avec I.E. il n'y a pas ce problème !)
0
dugenou Messages postés 6083 Date d'inscription mercredi 19 janvier 2005 Statut Contributeur Dernière intervention 30 juillet 2021 1 454
9 août 2008 à 09:47
Je ne suis pas un spécialiste de l'affichage des vidéos dans un site web, je te faisais simplement profiter de ma petite expérience dans ce domaine.
Je suis désolé de ne pas pouvoir t'aider davantage.
0
Conclusion : Pas de réponse sur la méthode d'activer la vidéo sous firefox ???
sauf google vidéo :)
0
marcetch64 > Mounir
4 févr. 2009 à 13:02
Bonjour

Le code que j'ai donné l'année dernière (voir plus haut dans les posts) fonctionne sous IE7, Firerefox 3, Opéra 9.26, Safari 3
Testez le lien ci-dessous et affichez la source dans votre navigateur :
http://www.oloron-ste-marie.fr/video_oloron.htm
A bientôt
Marc
0
bonjour,

ca peut servir : pour firefox, pour afficher une video en 320*240 (par exemple), utilisez width="320" height="270" (rajoutez environ 30 en hauteur, et vous verrez votre barre de controle).
Cordialement.
0