Critère ou dans formule matricielle excel

Résolu/Fermé
tagada5 Messages postés 15 Date d'inscription mardi 3 juillet 2012 Statut Membre Dernière intervention 29 juillet 2012 - 23 juil. 2012 à 20:30
tagada5 Messages postés 15 Date d'inscription mardi 3 juillet 2012 Statut Membre Dernière intervention 29 juillet 2012 - 24 juil. 2012 à 00:13
Bonjour,
Est-il possible d'insérer un critère "ou" dans une formule matricielle de type:
SOMME((A2:A130=1)*(B2:B130=2) ?
Ce que je voudrais obtenir c'est la somme des (A2:A130=1)et(B2:B130=2)ou(B2:B130=3) par exemple. J'ai déjà essayé plusieurs écritures, comme celles ci-dessous mais ça ne fonctionne pas.
SOMME((A2:A130=1)*(B2:B130=2)*OU(A2:A130=1)*(B2:B130=3)*1)
SOMME((A2:A130=1)*(B2:B130=2)*OU(B2:B130=3)*1)
Merci pour votre aide

2 réponses

tuxboy Messages postés 994 Date d'inscription lundi 23 juillet 2012 Statut Membre Dernière intervention 28 mai 2019 188
23 juil. 2012 à 23:39
{=SOMME((A2:A130=1)*(B2:B130=2)+SOMME((A2:A130=1)*(B2:B130=3))}
1
tagada5 Messages postés 15 Date d'inscription mardi 3 juillet 2012 Statut Membre Dernière intervention 29 juillet 2012
23 juil. 2012 à 23:51
Ce que j'ai trouvé est SOMME((A2:A130=1)*(B2:B130=2)+(A2:A130=1)*(B2:B130=3)). Ca marche bien mais le problème est que comme j'ai 4 ou 5 "+" c'est très long à écrire, donc je chercherais quelque chose de plus simple.
0
Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 926
Modifié par Mytå le 23/07/2012 à 23:59
Re le forum

Si tu as toujours les mêmes plages de cellules
=SOMMEPROD(((A2:A130=1)*(B2:B130={2.3.4.5})))
Mytå

P.S. Dans certaine version d'Excel le point (.) doit être remplacer par un antislash (\)
0
tagada5 Messages postés 15 Date d'inscription mardi 3 juillet 2012 Statut Membre Dernière intervention 29 juillet 2012
24 juil. 2012 à 00:13
Super merci ça marche très bien avec les points!
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 288
23 juil. 2012 à 20:56
Ce sujet est il encore d'actualité???
0
tagada5 Messages postés 15 Date d'inscription mardi 3 juillet 2012 Statut Membre Dernière intervention 29 juillet 2012
23 juil. 2012 à 23:10
Oui c'est encore d'actualité, enfin j'ai trouvé une solution avec des + mais l'écriture est vraiment lourde car je veux calculer entre 4 et 5 "ou" dans la même formule.
0
Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 926
23 juil. 2012 à 23:52
Salut le forum

=SOMMEPROD(((A2:A130=1)*(B2:B130=2))+((A2:A130=1)*(B2:B130=3)))


Mytå
0