Formule index equiv excel 2003

Résolu/Fermé
elea25 Messages postés 12 Date d'inscription mardi 5 avril 2011 Statut Membre Dernière intervention 28 avril 2016 - 19 juil. 2012 à 15:39
elea25 Messages postés 12 Date d'inscription mardi 5 avril 2011 Statut Membre Dernière intervention 28 avril 2016 - 19 juil. 2012 à 16:34
Bonjour,

Je suis sous excel 2003, j'utilise la formule index equiv qui fonctionne très bien pour rapatrier les cellules non vides de ma plage de référence, mais pour les cellules vides, j'ai des "0" dans les cellules de destination. L'un d'entre vous peut il me dire comment conserver mes cellules de destination vide et non avec "0" ?

J'aurais voulu aussi conserver la mise en forme d'origine (taille de police, couleur etc) mais rien à faire... est-ce seulement possible ou est ce que je cherche en vain ??

Merci de votre aide ! (je précise que je ne sais pas utiliser les macros)

3 réponses

Raymond PENTIER Messages postés 56854 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 décembre 2022 17 182
19 juil. 2012 à 15:52
Ta formule récupère LES VALEURS DES CELLULES.
Or une cellule vide vaut zéro ...
et le format n'est pas une valeur !
0
Raymond PENTIER Messages postés 56854 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 décembre 2022 17 182
19 juil. 2012 à 15:53
Essaie de mettre un caractère comme ² ou & dans les cellules vides ...
0
pijaku Messages postés 12259 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 709
Modifié par pijaku le 19/07/2012 à 16:04
Bonjour,
Salut Raymond, toujours en retraite??? (Si ça tombe cet antillais à 32 ans ;-) ...)
Ta formule récupère LES VALEURS DES CELLULES.
Or une cellule vide vaut zéro

C'est pourquioi il faut changer de formule et la combiner avec un SI :
=SI(TaFormule=0;"";TaFormule)
ou TaFormule est bien entendu ton INDEX(EQUIV blabla)


EDIT : A titre d'exemple :
=DECALER(INDEX($A$1:$A$26;EQUIV(A19;$A$1:$A$26;0);1);0;2)
devient :
=SI(DECALER(INDEX($A$1:$A$26;EQUIV(A19;$A$1:$A$26;0);1);0;2)=0;"";DECALER(INDEX($A$1:$A$26;EQUIV(A19;$A$1:$A$26;0);1);0;2))
Cordialement,
Franck P
0
elea25 Messages postés 12 Date d'inscription mardi 5 avril 2011 Statut Membre Dernière intervention 28 avril 2016 2
19 juil. 2012 à 16:34
merci merci beaucoup d'avoir répondu si vite !

2 minutes pour régler un probleme qui me prend la tete depuis 2 heures :) et voilà plus de "0" dans les cellules !
0