Sommeprod sur Excel

[Résolu/Fermé]
Signaler
-
 mp -
Bonjour,

j'essaie de faire un tableau excel où il y aura une colonne "Description", "Quantité vendue", "Valeur totale de la vente" et une "Valeur cumulée". Pour la colonne "Valeur cumulée" je voudrais faire en sorte que excel calcule la "Valeur totale" des lignes avant mais SEULEMENT si dans ma colonne "Description" c'est écrit "Vente".

Au départ, je voulais faire une formule du type:

=SOMME($D$12:D12) SOMME.SI(B11:B24;"Vente";D11:D24)

Mais cela n'existe pas XD, à moins qu'il manque quelque chose avant mon SOMME.SI... J'ai essayé le *, sans plus...

Je me suis dit que peut-être qu'en utilisant SOMMEPROD cela fonctionnerait? Par contre, je suis très débutante en excel alors je ne sais pas trop comment appliquer cette formule...

Merci

3 réponses

Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Bonsoir
On ne voit pas ce que vient faire la somme D12 devant la formule somme si
Pourquoi ne pas faire simplement:
=SOMME.SI(B11:B24;"Vente";D11:D24)
qui vous donnera le total des montants de D11:D24 pour les lignes contenant Vente en B
Ca ne suffit pas?
et si vous voulez tirer cette formule de 11 à 24 et n'afficher le cumul qu'en face de la dernière ligne contenant VENTE:
=SI(NB.SI(B11:$B$24;"Vente")>1;"";SOMME.SI($B$11:$B$24;"Vente";$D$11:$D$24))
Attention, noter bien la position du signe $ dans chaque adresse

crdlmnt
ne sommes nous pas seuls à comprendre ce que l'on explique?
Génial! Je crois que cette formule fonctionne! Par contre, il y a un petit problème. Lorsque je met la formule dans la première case (sous "Valeur Cumulée"), les résultats commence seulement à partir de la 3e ligne... donc mes deux premières lignes sont vides... Quoi faire?
En fait, ce que je remarque, c'est que le résultat se met à la fin de mon tableau. Est-ce qu'il y aurait une façon pour que je vois le cumulatif? Par exemple:


1 vente 10$ 10$
2 ventes 20$ 30$
6 ventes 60$ 90$

Sinon, c'est pas plus grave, je peux toujours me débrouiller avec seulement un résultat.

Merci :)
Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Bonjour
pour avoir la somme évolutive en ligne,avec les $ aux bons endroits:
sur la 1° ligne si elle est en 11
=SOMME.SI($B$11:B11;"Ventes";$D$11:D11)
et tirer sur la hauteur voulue

crdlmnt
Super! Tout fonctionne :) Merci beaucoup!