Reconnaitre un format temps sous excel [Résolu/Fermé]

Signaler
-
 steff -
Bonjour,
j'ai besoin d'un conseil sur l'utilisation d'excel.
Je voudrais qu'excel reconnaisse, dans une formule, un format temps.
Je m'explique et j'illustre: en B2 (par exemple) le code d'une balise (31) et en B3 le temps de passage à la balise (ex: 00:12:27) ou (en cas de non passage à la balise) "-----". Je voudrais, par une formule commençant par SI, demander à excel de déterminer si en B3 c'est un temps ou rien et d'afficher B2 si c'est un temps ou rien si il n'y a pas de passage. J'avais pensé à différentes solutions telle que =SI(B3=h:mm:ss;B2;"") mais cela ne marche pas. Y-a-t-il une solution ?
Merci pour votre aide



3 réponses

Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
6 847
Bonjour,

Tu peux très bien avoir un format temps dans ta cellule et y avoir un texte "----".

Teste plutôt le contenu :
=SI(ESTNUM(A1);A1;"")
en mettant le format d'affichage souhaité.

eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
54308
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 juillet 2021
16 288
Oui.
Il faut utiliser la fonction CELLULE.
Je te recommande de regarder ce qu'en dit l'AIDE d'Excel.

Si tu as 12:33 en C7, 12:33:45 en C8, 05-nov en C9 et 05/11/12 en C10, la formule =CELLULE("format";C7) donne le résultat H4
=CELLULE("format";C8) donne le résultat H3
=CELLULE("format";C9) donne le résultat D2
=CELLULE("format";C10) donne le résultat D1
etc, ce qui te permet de connaître le format utilisé dans chaque cellule.
Je vous remercie pour vos réponses très rapides.
Je retiens la solution d'Eric qui fonctionne tel que je le souhaitais.
Raymond, bonne continuation au soleil.

Je continue mon travail et j'aurais, sans doute, besoin de faire appel à vos connaissances dans quelque temps