Crée un message en excel 2007

[Résolu/Fermé]
Signaler
Messages postés
97
Date d'inscription
jeudi 21 juin 2012
Statut
Membre
Dernière intervention
3 avril 2015
-
Messages postés
97
Date d'inscription
jeudi 21 juin 2012
Statut
Membre
Dernière intervention
3 avril 2015
-
salut tous le monde
j'ai une problème en excel je veux crée une message qui me permet d'invertir avant 10 jours de délai d'échéance
comment je fait ???

13 réponses

Messages postés
54666
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2021
16 568
Tu vas dans Données/Validation de données et tu crèes une règle de validation.
Messages postés
97
Date d'inscription
jeudi 21 juin 2012
Statut
Membre
Dernière intervention
3 avril 2015

comment j'ai essayé et j'ai pas u de résultat
comment je test sur une cellule qui contient déjà une date??
moi je veut que avant l'arrivage10 jours de date d'échéance qui apparait dans le cellule un message apparaitre et m'invertir qu'il reste 10 jours
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Bonjour
Le message ne pourra pas apparaître dans la cellule puisqu'il y a la date.
Par contre il peut apparaître dans la cellule d'à coté avec cette formule (exemple en B1 pour date en A1)
=SI(ET(A1>=AUJOURDHUI();A1=<AUJOURDHUI()+10);"votre message entre guillemets";"")
Le message s'affichera pour toutes les dates comprises entre le jour en cours et le jour en cours +10, limites incluses.

Mais vous pouvez plus simplement utiliser la mise en forme conditionnelle pour passer par exemple une couleur d'alerte sur votre cellule date.
Si vous voulez des précisions, revenez en précisant "l'age" de votre excel.
crdlmnt
ne sommes nous pas seuls à comprendre ce que l'on explique?
Messages postés
97
Date d'inscription
jeudi 21 juin 2012
Statut
Membre
Dernière intervention
3 avril 2015

merci pour l'explication c'est très gentille
moi j'utilise excel 2007.
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Bonjour
alors sur Excel 2007
sélectionner la cellule à formater
Ruban / onglet "Accueil" /Icone Mise en forme conditionnelle
dans la liste qui s'affiche:
"nouvelle règle"
dans la fenêtre: "utiliser une formule...."
dans le cadre, entrer la formule
=ET(A1>=AUJOURDHUI();A1=<AUJOURDHUI()+10)
cliquer sur "Format"
formatez comme souhaité
OK
si vous voulez un formatage supplémentaire:
nouvelle règle
et ajouter la ,nouvelle règle et le nouveau format
etc....
fermer avec OK

crdlmnt
Messages postés
17538
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 septembre 2021
4 728
Salut,

Cette formule dans une mise en forme conditionnelle devrait suffir
=A1<=AUJOURDHUI()+10
éventuellement avec la détection de cellule non vide
=ET(A1<>"";A1<=AUJOURDHUI()+10)
choisir un format de colorisation
Si les dates étaient saisies chaque jour il serait possible d'utiliser la Validation de données ce qui ne semble pas le cas

Pour une automatisation de la surveillance après il faut passer au VBA mais cela est il nécessaire ?

Sur le fichier exemple de A1 à A20 sans détection de cellule vide et de A21 à A40 pas de colorisation de cellule vide. il serait possible de coloriser la ligne de données si tu le souhaites

https://www.cjoint.com/?BFxwS2NN0fz

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Bonjour Mike

ta formule à le défaut d'afficher le même résultat si la date est dépassée, ce qui risque d'embrouiller la lecture recherchée.

pour être complet, il faut soit éliminer les dates dépassées comme proposé plus haut, soit entrer une condition depuis une autre cellule signalant que l'action a été réalisée:
par exemple avec OK en B1:

=ET(A1<>"";B1<>"OK";A1<=AUJOURDHUI()+10)

Crdlmnt
Messages postés
17538
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 septembre 2021
4 728
Bonjour mon ami,

Alors peut être comme cela

=ET(A1<AUJOURDHUI()+10;A1>AUJOURDHUI()-1)

tchin tchin... il est l'heure
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Merci pour l'apéro..

quant à la solution elle n'est pas très loin de la mienne , non ?? si??

voir ici soit un peu plus haut:

https://forums.commentcamarche.net/forum/affich-25436555-cree-un-message-en-excel-2007#5
Messages postés
17538
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
19 septembre 2021
4 728
Re,

En cherchant, des solutions ce n'est pas ce qui manque quand à yosra_miagi, ce doit être l'heure de la sieste
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
.. en fait je pense qu'il avait donc déjà la solution, et pas de raisons de revenir!

salut tous le monde merci pour vous aide
moi je veux cette format
=SI(ET(A1>=AUJOURDHUI();A1<=AUJOURDHUI()+10);"Il reste "(A1-AUJOURDHUI())"jours pour la date d'échéance";"pas encore")
çà d la date d'échéance se décrémente de 1 jours pour chaque jours passé

mais cette formule m'affiche qu'il y à un faux
je ne sé pas comment je fais
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Bonjour
=SI(A1<AUJOURDHUI();"";SI(ET(A1>=AUJOURDHUI();A1<=AUJOURDHUI()+10);"Il reste "&(A1-AUJOURDHUI())&" jours pour la date d'échéance";"pas encore"))
crdlmnt
Messages postés
97
Date d'inscription
jeudi 21 juin 2012
Statut
Membre
Dernière intervention
3 avril 2015

merciiiiiiii beaucoup Vaucluse ça marche
Messages postés
97
Date d'inscription
jeudi 21 juin 2012
Statut
Membre
Dernière intervention
3 avril 2015

est ce que elle est possible de mettre les cellules qui contient date inférieur à 10 en rouge de cette formule:
=SI(ET(A1>=AUJOURDHUI();A1<=AUJOURDHUI()+10);"Il reste "(A1-AUJOURDHUI())"jours pour la date d'échéance";"pas encore")
Messages postés
26185
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 052
Oui avec la même formule, ou alors:, dans la MFC:

=NB.SI(cell;"*Il reste*")
qui formatera selon votre choix lorsque Il reste sera inscrit dans la cellule Cell
crdlmnt
Messages postés
97
Date d'inscription
jeudi 21 juin 2012
Statut
Membre
Dernière intervention
3 avril 2015

merciiiiiiiiiiiii beaucoup