Excel comptage plage variable

[Résolu/Fermé]
Signaler
Messages postés
13
Date d'inscription
vendredi 1 juin 2012
Statut
Membre
Dernière intervention
17 juin 2012
-
Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
-
Bonjour,

J'ai une liste de notes en colonne B mais le nombre change trés souvent, il peut y avoir 10 notes comme 50 notes.Plage B4:B50
j'ai des verifications de ces notes en colonne D avec plage D4:D50 , avec VRAI si la note en dessous de la moyenne, Pareil pour les colones suivantes avec des valeurs de controle différentes.

Je souhaite compter en Cellule D2 le nombre de notes en dessous de la moyenne , en Cellule E2 le nombre de notes en dessous de 12 ETC..


Mais comme le nombre de note est différent a chaque fois , mes résultats sont fausés.

Je souhaiterai ne compter que le nombre de notes réelles ( Affiché en B2)

Est il possible de changer ma formules en D4 (=NB.SI(D4:Z50;VRAI)) pour que je puisse compter sur la plage qui correspond au nombre de notes et non pas jusqu' a 50.

MErci a vous
Voici mon exemple:

https://www.cjoint.com/?BFrmZGQMHcs







2 réponses

Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 886
Bonjour,

Tu n'es pas obligé d'utiliser une colonne intermédiaire :
=NB.SI(B4:B50;">=12")

eric
Messages postés
13
Date d'inscription
vendredi 1 juin 2012
Statut
Membre
Dernière intervention
17 juin 2012

Merci beaucoup Eriiic, je vais passer en mode résolu,
j'ai la meme question sur un fichier beaucoup plus complexe ,
puis je me permettre de poster une nouvelle question ?

Merci encore
Messages postés
24182
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 septembre 2021
6 886
Démarre un nouveau sujet, les intervenants regardent plus un sujet sans réponse.
Tu peux toujours mettre un lien vers lui ici
eric