Feuille de calculs de vacations horaires [Résolu/Fermé]

Signaler
-
 JPB -
Bonjour,
<config>Windows 7

J'aimerais connaître la formule qui me permettrait de gérer mes vacations journalières de travail à savoir :

si je travaille (par exemple) de 07:00 à 19:00 alors que ma vacation n'est que de 07h36 par jour (cette-ci apparaisse en nombre positif
mais que
si je travaille (par exemple) de 10:00 à 15:00 celle-ci apparaisse en nombre négatif

De même, quelle est la formule à mettre en oeuvre pour que du 1err du mois à la fin du mois je puisse connaître la somme des heures et minutes cumulées.

Merci de votre obligence.

JPB.

3 réponses

Messages postés
54124
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juin 2021
16 110
Autre méthode, qui ne t'oblige pas à modifier la paramétrage du calendrier d'excel :

En A, la date ; en B, l'heure d'entrée ; en C, l'heure de sortie
en D, la durée de travail ; en E, durée exécutée en plus ; en F, durée en moins
en G1, la durée contractuelle de 7h36

en D:D, la formule =C:C-B:B
en E:E, la formule =SI(D:D>$G$1;D:D-$G$1;0)
en F:F, la formule =SI(D:D+E:E=0;0;SI(D:D<$G$1;$G$1-D:D;0))

en ligne 1, les intitulés de champs (colonnes) ; en ligne 2, les totaux avec
en E2 la formule
=SI(SOMME(E3:E999)>SOMME(F3:F999);SOMME(E3:E999)-SOMME(F3:F999);0)
en F2 la formule
=SI(SOMME(E3:E999)<SOMME(F3:F999);SOMME(F3:F999)-SOMME(E3:E999);0)

à partir de la ligne 3, les enregistrements (saisies).

Et pour faire propre, aller dans les options avancées pour enlever le choix "Afficher un zéro dans les cellules qui ont une valeur nulle".
Version 2007 https://www.cjoint.com/?BFnsW6JETnp
Version 2003 https://www.cjoint.com/?BFnsY3XBbCy

Cordialement.
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

PHILOU,
Je tenais à vous remercier de la diligence dont vous avez fait preuve pour résoudre le problème soumis en ligne.

Je viens de terminer le tableau que je voulais mettre en oeuvre. Tout va très bien.

Encore mille merci pour votre gentilesse et votre professionnalisme.

JPB
Messages postés
5563
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
16 juin 2021
620
Bonjour

mettre vos données dans des cellules au format Horaire 00:00:00
mettre les options Excel 2010 Options avancées Utiliser le calendrier depuis 1904
colonne A arrivée 10:00:00
colonne B départ 15:00:00

en colonne C mettre cette formule =1-MOD(A10-B10;1) résultat 5:00:00
puis faire l'écart avec la journée type de 7:36:00
mettre cette valeur dans une cellule dans mon exemple A7
en colonne D mettre cette formule = C10 - $A$7 résultat -02:36:00