Excel: Somme à 2 conditions pour chaque ligne [Résolu/Fermé]

Signaler
-
 Guillaume -
Bonjour,

Je cherche à créer un tableur de contact et de présences pour une association.

Pour situer le contexte :
- Nous avons plusieurs sociétés membre (lignes de la feuille 1, nom de la société en Colonne A)
- Nous avons plusieurs contacts au sein de chaque société (lignes de la feuille 2, contenant le nom de la société membre du contact en colonne B)

Je cherche à obtenir une vue d'ensemble des présences par société en faisaint pour chaque ligne (société) la somme des contacts de cette société présents à chaque événement. Le premier exemple d'événement est en feuille 2, Colonne C.

Exemple du tableur : https://www.box.com/s/87c3ecbe669aeff67488

En gros, pour la société 1 (ligne 2), ça je voudrais avoir en Feuille1!C2 :
"Pour tout i, faire la somme des "Présent" de la colonne Feuille 2!Ci quand le nom de société du contact (Feuille 2!Bi) est le même que la société de cette ligne (Feuille 1, A2)"

J'ai essayé de bidouiller avec du NB.SI et du Si mais ça colle pas. Quelqu'un peut-il m'aider svp ?

Merci d'avance.


1 réponse

Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
541
Bonjour,

Avec la fonction SOMMEPROD
Dans la feuille Sociétés:

C2=SOMMEPROD((Contacts!$B$2:$B$40=Sociétés!A2)*(Contacts!$C$2:$C$40="O"))

https://www.cjoint.com/?BEesvTsQSlQ

Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

J'ai honteusement mis tout ce temps à répondre parce que j'étais parti sur tout autre chose...

MERCI ! C'est impeccable, tout pile poil comme je voulais.